Opened 7 years ago

Closed 7 years ago

#11077 closed Bug Report - General (Fixed)

Audio mixer not being muted

Reported by: stuartm Owned by: stuartm
Priority: critical Milestone: 0.26
Component: MythTV - Audio Output Version: Master Head
Severity: medium Keywords:
Cc: Ticket locked: no

Description

In master* we're not muting the audio device when Muted or at zero volume. On some systems this isn't enough to actually kill the audio.

  • This seems to be a regression although it may have happened months/years ago and I've only just noticed.

I'm using Mageia 2, pulseaudio isn't installed, audio device is configured as ALSA:default as is mixer. Mixer controls PCM (changing to master doesn't help). Muting the device properly through alsamixer does silence the audio.

Attachments (1)

alsa_mute.diff (942 bytes) - added by stuartm 7 years ago.

Download all attachments as: .zip

Change History (4)

comment:1 Changed 7 years ago by stuartm

Milestone: unknown0.26
Owner: changed from JYA to stuartm
Priority: minorcritical
Status: newaccepted

The attached patch changes it to actually mute the device, works as intended here and I will commit if there are no objections.

Changed 7 years ago by stuartm

Attachment: alsa_mute.diff added

comment:2 Changed 7 years ago by Kenni Lund [kenni a kelu dot dk]

Milestone: 0.260.26.1

comment:3 Changed 7 years ago by stuartm

Milestone: 0.26.10.26
Resolution: Fixed
Status: acceptedclosed
Note: See TracTickets for help on using tickets.