Opened 7 years ago

Closed 6 years ago

#11115 closed Bug Report - General (Invalid)

MythTV unable to play this video with vdpau

Reported by: Kenni Lund [kenni a kelu dot dk] Owned by:
Priority: minor Milestone: unknown
Component: MythTV - Video Playback Version: Master Head
Severity: medium Keywords:
Cc: Ticket locked: no

Description

Recently some of the shows broadcasted on the Danish TV channel "Kanal 4" became unplayable with the VDPAU-profiles in MythTV. The sound is fine, but the picture gets artifacts every few seconds.

I'm fairly sure this isn't a local issue, as the recordings are playable on the same systems with mplayer+vdpau ("mplayer -vo vdpau -vc ffmpeg12vdpau file.mpg"). It also works fine with any of the non-VDPAU MythTV profiles and with mythffplay.

I've stripped out a 15MB sample which should illustrate the issue:
http://dl.dropbox.com/u/87953940/Kanal4_sample_with_playback_issues.mpg

Log from "mythavtest -v playback" has been attached.

MythTV Version : v0.26-rc2-14-gd052695
MythTV Branch : master
Network Protocol : 75
Library API : 0.26.20120822-1
QT Version : 4.8.1
Options compiled in:
 linux profile use_hidesyms using_alsa using_oss using_pulse using_pulseoutput using_backend using_bindings_perl using_bindings_python using_bindings_php using_crystalhd using_dvb using_firewire using_frontend using_hdhomerun using_ceton using_hdpvr using_iptv using_ivtv using_joystick_menu using_libcec using_libcrypto using_libdns_sd using_libxml2 using_lirc using_mheg using_opengl_video using_qtwebkit using_qtscript using_qtdbus using_v4l2 using_x11 using_xrandr using_xv using_bindings_perl using_bindings_python using_bindings_php using_mythtranscode using_opengl using_vaapi using_vdpau using_ffmpeg_threads using_live using_mheg using_libass using_libxml2

Attachments (1)

mythavtest.20120923155518.13842.log (40.1 KB) - added by Kenni Lund [kenni a kelu dot dk] 7 years ago.
mythavtest -v playback

Download all attachments as: .zip

Change History (4)

Changed 7 years ago by Kenni Lund [kenni a kelu dot dk]

mythavtest -v playback

comment:1 Changed 7 years ago by Kenni Lund [kenni a kelu dot dk]

Likely a duplicate of #10181. I'm leaving this ticket open, as it contains a sample.

comment:2 Changed 7 years ago by Kenni Lund [kenni a kelu dot dk]

Ok, it turns out that the issue is not limited to the Danish channel "Kanal 4". The SD-versions of "Kanal 5" and "6'eren" are also affected by the issue. This makes sense, since all three channels originates from the same TV station, SBS TV.

Furthermore, I've just found out that the default player on my Mac, Quicktime Player v10.2, fails to play the video as well. Instead of showing artifacts, Quicktime shows a green screen every few seconds.

So apparently the broadcaster uses some encoding settings which works for almost all players, just not the VDPAU implementation in MythTV and the Quicktime Player on Mac OS X.

In case someone wants to take a stab at improving the VDPAU playback-compatibility in MythTV, here's another larger sample (87MB), this time from Kanal 5:
http://dl.dropbox.com/u/87953940/Kanal5_sample_with_playback_issues.mpg

comment:3 Changed 6 years ago by Kenni Lund [kenni a kelu dot dk]

Resolution: Invalid
Status: newclosed

The cable company acknowledged that they had made "some error" in their encoding configuration and fixed it a week ago. After they implemented their fix, the affected channels have been playing nicely with MythTV+VDPAU.

Since the software decoder in MythTV and mplayer with VDPAU is capable of decoding the sample correctly, it would still be preferable if the VDPAU implementation in MythTV was more robust and was able to do this as well. I'll leave the sample online for now, in case someone want to improve the decoder, but I'll close the ticket as we have plenty of open tickets already.

Note: See TracTickets for help on using tickets.