Modify
Warning Please read the Ticket HowTo before creating or commenting on a ticket. Failure to do so may cause your ticket to be rejected or result in a slower response.

Opened 19 months ago

Closed 15 months ago

#11174 closed Bug Report - General (Fixed)

LiveTV Can't Rewind Back To Previous Programs

Reported by: wnhtr2011@… Owned by: stichnot
Priority: minor Milestone: 0.26.1
Component: MythTV - Video Playback Version: 0.26-fixes
Severity: medium Keywords:
Cc: Ticket locked: no

Description

After upgrading from 0.24 to 0.26.0-fixes, I have noticed (in LiveTV) that I cannot rewind before the beginning of the current program. When I try to rewind, it stops and won't go back to the previous program(s) that I was watching. In addition, when trying to rewind past the start of the current program, I see the same jittery playback as reported in ticket 11159. The only way to recover from jittery playback is to exit and go back to LiveTV.

To reproduce this, just go into LiveTV and start watching TV. Once the current program ends, and a new program has started, try to rewind back to the 1st program. You will see that you cannot, and the video will start jittering like crazy.

This is a bad problem for me because I watch a lot of sporting events (football/baseball) that go past the scheduled program end time, and I want to rewind to see previous plays.

Attachments (2)

mythfrontend.log.gz (202.6 KB) - added by wnhtr2011@… 19 months ago.
Frontend Log
mythfrontend-ver.txt (895 bytes) - added by wnhtr2011@… 19 months ago.
Mythfrontend --version

Download all attachments as: .zip

Change History (8)

Changed 19 months ago by wnhtr2011@…

Frontend Log

Changed 19 months ago by wnhtr2011@…

Mythfrontend --version

comment:1 Changed 16 months ago by inbox73pe@…

I and many other users (take a look at the mythtv mailing list) have the same problem.

Rewinding is only possible in the current program in LiveTV. Sometimes it is possible to jump to the previous program with RWNDSTICKY but in most cases the frontend crashes.

Version 0.27 is also affected. I'm using the lastest 0.26.0-fixes and master branch.

comment:2 Changed 16 months ago by wagnerrp

  • Ticket locked set

If the problem were unverified, it would be closed as such. No "me toos" on the bug system.

http://code.mythtv.org/trac/wiki/TicketHowTo#WhatNext

comment:3 Changed 16 months ago by stichnot

  • Component changed from MythTV - Recording to MythTV - Video Playback
  • Milestone changed from unknown to 0.27
  • Owner changed from danielk to stichnot
  • Status changed from new to accepted

comment:4 Changed 15 months ago by Jim Stichnoth <jstichnoth@…>

In fd3d2c1de2bc6377632c5c82f1dc8f455b0c8fd8/mythtv:

Allow seeking back through the live TV chain.

Fixes a regression introduced in 0.25. Refs #11174.

comment:5 Changed 15 months ago by Jim Stichnoth <jstichnoth@…>

In 8ca4caf0c0ed3debd0659c4170970a37fb7dc916/mythtv:

Allow seeking back through the live TV chain.

Fixes a regression introduced in 0.25. Refs #11174.

comment:6 Changed 15 months ago by stichnot

  • Milestone changed from 0.27 to 0.26.1
  • Resolution set to Fixed
  • Status changed from accepted to closed
  • Ticket locked unset

Add Comment

Modify Ticket

Action
as closed .
The resolution will be deleted. Next status will be 'new'.
Author


E-mail address and user name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.