Opened 7 years ago

Closed 7 years ago

Last modified 7 years ago

#11176 closed Bug Report - General (Invalid)

Access denied for user 'mythtv'@'localhost' (using password: YES)

Reported by: jaimecoll_6@… Owned by:
Priority: minor Milestone: unknown
Component: MythTV - General Version: 0.25.2
Severity: medium Keywords:
Cc: Ticket locked: no

Description (last modified by Raymond Wagner)

jaime@linux-2lvn:~> mythtvsetup
2012-10-15 10:27:51.150645 C  mythtv-setup version:  [v0.25.2] www.mythtv.org
2012-10-15 10:27:51.150657 C  Qt version: compile: 4.7.4, runtime: 4.7.4
2012-10-15 10:27:51.150661 N  Enabled verbose msgs:  general
2012-10-15 10:27:51.150675 N  Setting Log Level to LOG_INFO
2012-10-15 10:27:51.150705 I  Added logging to the console
2012-10-15 10:27:51.150709 I  Added database logging to table logging
2012-10-15 10:27:51.150753 N  Setting up SIGHUP handler
2012-10-15 10:27:51.150938 N  Using runtime prefix = /usr
2012-10-15 10:27:51.150949 N  Using configuration directory = /home/jaime/.mythtv
2012-10-15 10:27:51.151031 I  Assumed character encoding: ca_ES.UTF-8
2012-10-15 10:27:51.151274 N  Empty LocalHostName.
2012-10-15 10:27:51.151279 I  Using localhost value of linux-2lvn
2012-10-15 10:27:51.159794 E  Unable to connect to database!
2012-10-15 10:27:51.159808 E  Driver error was [1/1045]:
QMYSQL: Unable to connect
Database error was:
Access denied for user 'mythtv'@'localhost' (using password: YES)

Attachments (1)

konsole.jpeg (212.6 KB) - added by jaimecoll_6@… 7 years ago.
not let me access mythtv and creates a loop

Download all attachments as: .zip

Change History (3)

Changed 7 years ago by jaimecoll_6@…

Attachment: konsole.jpeg added

not let me access mythtv and creates a loop

comment:1 Changed 7 years ago by Raymond Wagner

Description: modified (diff)
Resolution: Invalid
Status: newclosed
Version: Unspecified0.25.2

Please read the install documentation.

http://www.mythtv.org/docs/mythtv-HOWTO-6.html#ss6.2

Trac is intended for bug tracking, not user support. For user support, please see the IRC channel or mailing list.

http://www.mythtv.org/support

comment:2 Changed 7 years ago by jaimecoll_6@…

I solved the problem by doing the following: 1.Download MythTV open source. 2.Open the database folder: mc.sql a file. Open it and found this: CREATE DATABASE IF NOT EXISTS mythconverg; GRANT ALL ON mythconverg. * TO mythtv @ localhost IDENTIFIED BY "mythtv"; FLUSH PRIVILEGES; GRANT CREATE TEMPORARY TABLES ON mythconverg. * TO mythtv @ localhost IDENTIFIED BY "mythtv"; FLUSH PRIVILEGES; ALTER DATABASE mythconverg DEFAULT CHARACTER SET utf8 COLLATE utf8_general_ci;

  1. Open Mysql and apply point 2
  2. privileges on the router and Mythtv Mysql: might not work but you give privileges on the firewall.

5.Abrir Yast> add mysql and mythbackend groups to access MythTV options. My system is the open suse 12.1 and doing this has worked for me

Note: See TracTickets for help on using tickets.