Opened 7 years ago

Closed 7 years ago

Last modified 7 years ago

#11211 closed Bug Report - Hang/Deadlock (Fixed)

Live Analog TV not working

Reported by: jharbestonus@… Owned by: Jim Stichnoth
Priority: minor Milestone: 0.26.1
Component: MythTV - Video Playback Version: 0.26-fixes
Severity: medium Keywords: analog livetv
Cc: Ticket locked: no

Description

When attempting to watch live TV(Analog only) either mythfrontend hangs, or it gives the "Error opening jump program file".

I have NO problems watching completed analog programs that had been recorded from the referenced tuner.

My digital tuner is an HDHR3US, and I am having no problems with digital ATSC live tv or with recordings.

VERSION information:

mythbackend --version Please attach all output as a file in bug reports. MythTV Version : v0.26.0-28-ge3087dd MythTV Branch : fixes/0.26 Network Protocol : 75 Library API : 0.26.20120822-1 QT Version : 4.8.1 Options compiled in: linux profile use_hidesyms using_alsa using_oss using_pulse using_pulseoutput using_backend using_bindings_perl using_bindings_python using_bindings_php using_crystalhd using_dvb using_firewire using_frontend using_hdhomerun using_ceton using_hdpvr using_iptv using_ivtv using_joystick_menu using_libcec using_libcrypto using_libdns_sd using_libxml2 using_lirc using_mheg using_opengl_video using_qtwebkit using_qtscript using_qtdbus using_v4l2 using_x11 using_xrandr using_xv using_bindings_perl using_bindings_python using_bindings_php using_mythtranscode using_opengl using_vaapi using_vdpau using_ffmpeg_threads using_live using_mheg using_libass using_libxml2

mythfrontend --version xprop: unable to open display Please attach all output as a file in bug reports. MythTV Version : v0.26.0-28-ge3087dd MythTV Branch : fixes/0.26 Network Protocol : 75 Library API : 0.26.20120822-1 QT Version : 4.8.1 Options compiled in: linux profile use_hidesyms using_alsa using_oss using_pulse using_pulseoutput using_backend using_bindings_perl using_bindings_python using_bindings_php using_crystalhd using_dvb using_firewire using_frontend using_hdhomerun using_ceton using_hdpvr using_iptv using_ivtv using_joystick_menu using_libcec using_libcrypto using_libdns_sd using_libxml2 using_lirc using_mheg using_opengl_video using_qtwebkit using_qtscript using_qtdbus using_v4l2 using_x11 using_xrandr using_xv using_bindings_perl using_bindings_python using_bindings_php using_mythtranscode using_opengl using_vaapi using_vdpau using_ffmpeg_threads using_live using_mheg using_libass using_libxml2

My analog tuner is an HVR-2250 and was working fine prior to my upgrading from .25-fixes on October 27, 2012.

I am running mythbuntu 12.04 64bit.

I will be attaching logs from the backend and the frontend for this momentarily.

Attachments (2)

mythbackend.20121031140317.10223.log (37.5 KB) - added by jharbestonus@… 7 years ago.
Backend Log during attempt to do live analog tv
mythfrontendtuningproblem.log (50.1 KB) - added by jharbestonus@… 7 years ago.
myrhfrontend log during analog live tv attempt.

Download all attachments as: .zip

Change History (9)

Changed 7 years ago by jharbestonus@…

Backend Log during attempt to do live analog tv

Changed 7 years ago by jharbestonus@…

myrhfrontend log during analog live tv attempt.

comment:1 Changed 7 years ago by Raymond Wagner

Priority: majorminor
Type: Bug Report - GeneralBug Report - Hang/Deadlock

comment:2 Changed 7 years ago by jharbestonus@…

Ok, thanks, I wasn't sure if they were duplicate since 11212 was watching an analog recording in process.

comment:3 Changed 7 years ago by mythtv@…

Just wanted to mention I have exactly the same issue with 0.26-fixes. I have a PVR-250 and a DVB card in my system. The DVB card works fine in all cases. However, the PVR-250 hangs indefinitely when trying to watch Live TV (even though the actual data gets properly written to the file) requiring mythfrontend to be killed. Additionally, attempting to watch a recording in progress takes quite a while (several minutes) to actually start playing. Playing back scheduled recordings made by the PVR-250 after they've finished recording works without issue.

Happy to provide additional info if useful.

comment:4 Changed 7 years ago by skd5aner <skd5aner@…>

Also see #11229, which could be related, and contains backtraces

comment:5 Changed 7 years ago by Jim Stichnoth

Component: MythTV - GeneralMythTV - Video Playback
Milestone: unknown0.26.1
Owner: set to Jim Stichnoth
Status: newaccepted

comment:6 Changed 7 years ago by Jim Stichnoth

Resolution: Fixed
Status: acceptedclosed

Fixed in a1b9b1f94a774710443637de034c661618e5baa3.

Note that this fixes a specific regression introduced in 0.26. Live TV bugs present in 0.25 may still be lurking.

comment:7 Changed 7 years ago by jharbestonus@…

I am confirming that this did indeed fix my problem with .26 as I indicated when opened.

Thanks stichnot!

Note: See TracTickets for help on using tickets.