Opened 6 years ago

Closed 6 years ago

#11275 closed Patch - Bug Fix (Fixed)

Still DVD menus with audio sometimes times out immediately

Reported by: peper03@… Owned by: stuartm
Priority: minor Milestone: 0.27
Component: MythTV - DVD Playback Version: 0.26-fixes
Severity: medium Keywords:
Cc: Ticket locked: no

Description

If no audio codec has been created, the audio data in a still DVD menu with audio is not processed. As there is no continuous video data and the audio data is not processed, the menu cell times out almost immediately and causes the DVD's cell's 'post' instructions to be executed, which, depending on the DVD, can cause a jump somewhere else. In this case, it is not possible to navigate the menu.

The problem is not actually specific to DVD menus but is most likely to occur in this scenario as there is only audio data to provide timing.

The attached patch re-enables audio decoding if an audio stream appears.

Attachments (1)

0001-kDecodeAudio-is-now-re-enabled-if-an-audio-stream-be.patch (2.4 KB) - added by peper03@… 6 years ago.

Download all attachments as: .zip

Change History (3)

Changed 6 years ago by peper03@…

comment:1 Changed 6 years ago by stuartm

Milestone: unknown0.27
Owner: set to stuartm
Status: newaccepted

comment:2 Changed 6 years ago by stuartm

Resolution: Fixed
Status: acceptedclosed

Fixed in [b082334c]

Note: See TracTickets for help on using tickets.