Opened 7 years ago

Closed 7 years ago

#11356 closed Bug Report - General (Fixed)

Current frame count in H.264 playback incorrect

Reported by: stuartm Owned by: Jim Stichnoth
Priority: blocker Milestone: 0.27
Component: MythTV - Video Playback Version: Master Head
Severity: high Keywords:
Cc: Ticket locked: no

Description (last modified by stuartm)

At some point in the last 2-3 weeks the calculation of current position in H.264 recordings from BBC One HD, BBC HD and possibly others in UK has significantly wrong.

For BBC HD it seems that every 8th frame is not counted toward the framesPlayed total (we ignore frames with 'no video', possibly B frames) and this can ultimately result in the position being behind actual by several minutes. This leads to bookmarks being set in the wrong place.

A sample of BBC HD is in the samples store.

EDIT: C4 HD issue previously described isn't reproducible so I've removed the detail of that to avoid confusion.

Change History (9)

comment:1 Changed 7 years ago by stuartm

Component: MythTV - GeneralMythTV - Video Playback

comment:2 Changed 7 years ago by Jim Stichnoth

Owner: set to Jim Stichnoth
Status: newaccepted

comment:3 Changed 7 years ago by stuartm

Description: modified (diff)
Summary: Current frame count in H.264 playback incorrect, playback ends earlyCurrent frame count in H.264 playback incorrect

comment:4 Changed 7 years ago by mythtv@…

This is almost certainly caused by commit 590f161. BBC HD has no IDRs. You need to use I frames for BBC HD to play back correctly.

comment:5 Changed 7 years ago by stuartm

It's not unfortunately. Most obviously because that change only affects seektables generated through mythcommflag which isn't the case for recordings. Just for good measure we reverted that change and tried without. Current working theory is that it was the last ffmpeg resync.

comment:6 Changed 7 years ago by stuartm

It's been traced by a user to [d34833f2], I've confirmed that reverting this commit fixes the issue.

 Temporary fix for #11159: Fix playback of HD-PVR recording
 This revert FFmpeg commit bfca35114ae174bbabd88526379d95d4022a98b1
 (ref https://ffmpeg.org/trac/ffmpeg/ticket/2062)

comment:7 Changed 7 years ago by stuartm

It's also been noted that there is a stutter/flicker caused by the same commit that is probably explained by fact that every eighth frame is not being rendered.

comment:8 Changed 7 years ago by Martin Long <martin@…>

Can this also be fixed in 26-fixes please? It's been making my eyes wobble since I installed this update. It seems like a massive regression.

comment:9 Changed 7 years ago by JYA

Resolution: Fixed
Status: acceptedclosed
Note: See TracTickets for help on using tickets.