Opened 7 years ago

Closed 6 years ago

Last modified 6 years ago

#11478 closed Bug Report - General (Invalid)

when second backend is running live tv is not starting

Reported by: walter@… Owned by:
Priority: minor Milestone: unknown
Component: MythTV - General Version: 0.26-fixes
Severity: medium Keywords:
Cc: Ticket locked: no

Description

following setup: one master backend with frontend; several other computers with frontend connecting to this master backend. Since in the ubuntu stack, the backend is also installend on the other computers. By default these backend are also running.

When a backend on one other computer is running, the live tv fails to start. When I stop other backends live tv start correctly.

Walter

Attachments (5)

live tv failing (5.5 KB) - added by walter@… 7 years ago.
masterbackend log when failing
live tv working (3.6 KB) - added by walter@… 7 years ago.
masterback log when only one backend running and it is working
log on tv masterbackend.txt (2.7 KB) - added by anonymous 7 years ago.
log on frontend zonnebloem.txt (3.6 KB) - added by anonymous 7 years ago.
log from second backend.txt (3.0 KB) - added by walter@… 7 years ago.

Download all attachments as: .zip

Change History (11)

Changed 7 years ago by walter@…

Attachment: live tv failing added

masterbackend log when failing

Changed 7 years ago by walter@…

Attachment: live tv working added

masterback log when only one backend running and it is working

comment:1 Changed 7 years ago by Raymond Wagner

Status: newinfoneeded_new

The logs say your slave backend keeps disconnecting and reconnecting. We need to see the logs from both your frontend and slave backend.

Changed 7 years ago by anonymous

Attachment: log on tv masterbackend.txt added

Changed 7 years ago by anonymous

Changed 7 years ago by walter@…

Attachment: log from second backend.txt added

comment:2 Changed 7 years ago by walter@…

I loaded the logs from a test; logs from the frontend, and logs from the second backend and logs from masterbackend.

When I stop the second backend, livetv works ok.

Walter

comment:3 Changed 6 years ago by sphery

Walter,

The error:

Apr 8 21:10:26 zonnebloem mythlogserver: mythfrontend[32357]: E CoreContext? livetvchain.cpp:277 (GetEntryAt?) It appears that your backend may be misconfigured. Check your backend logs to determine whether your capture cards, lineups, channels, or storage configuration are reporting errors. This issue is commonly caused by failing to complete all setup steps properly. You may wish to review the documentation for mythtv-setup.

is indicating a misconfiguration of your backend--likely either a broken Input Connections configuration, or (I'm guessing in this situation) due to use of a host name for the IP address:

Apr 8 21:10:19 zonnebloem mythlogserver: mythfrontend[32357]: I CoreContext? mythcorecontext.cpp:375 (ConnectCommandSocket?) MythCoreContext?: Connecting to backend server: tv:6543 (try 1 of 1)

It looks like you've specified 'tv' as the IP address. MythTV requires the use of an IP address for all IP address fields (including master backend IP address and "this server" IP address). Please run mythtv-setup on all hosts and ensure both IP address fields are properly specified using addresses, not names, and see if that fixes the issue. If you have questions about reconfiguring your addresses, please ask on the mythtv-users mailing list.

If that doesn't help, we'll need /full/ log files for the 3 hosts. Please see http://www.mythtv.org/wiki/Posting_Logs (especially section 1, 'Getting Useful Logs'). (Note that if it is the described misconfiguration, it would have been much easier to find had you submitted full logs from startup through the error.) Thanks.

comment:4 Changed 6 years ago by walter@…

Hi mdean,

thanks for the feedback. I have now de-installed the backend on all other computers, except for the 'backend' computer. Now all is working ok. This is also the better setup as the other computers are only clients and I don't need there any master functionality. It is only a bit extra effort on the ubuntu stack to get the backend de-installed. But that is not a mythtv issue. It could be indeed that mythtv requires an ip-address instead of a hostname. I checked the documentation once more and indeed it only refers to an IP-address, not a host name. Anyway it remains strange that this is causing issues only on the live tv and is not giving issues on any other part of the application. To me it feels a bit that mythtv is not 100% consitent on how the parameters work or also how it is setting up the connection to a backend (it works without a local backend running, not with a local backend running which is odd, it means there is something in the process taking the connection information from different locations). From my side the issue can be closed. note: there are only 2 computers involved in this issue, not 3 (refering to your request to log files from 3 hosts).

Walter

comment:5 Changed 6 years ago by sphery

Resolution: Invalid
Status: infoneeded_newclosed

comment:6 Changed 6 years ago by sphery

And thanks for the quick reply.

Note: See TracTickets for help on using tickets.