Opened 7 years ago

Closed 7 years ago

Last modified 7 years ago

#11510 closed Bug Report - General (Fixed)

MythTV will not configure due to issues with TagLib

Reported by: ramccor@… Owned by: paulh
Priority: minor Milestone: 0.27
Component: MythTV - configure script Version: Master Head
Severity: medium Keywords:
Cc: Ticket locked: no

Description

taglib requres libstdc++ but doesnt show it in the taglib-config --libs output, so the configure script fails to detect it properly.

Change History (10)

comment:1 Changed 7 years ago by ramccor@…

I should state that I have ONLY verified that the information above is correct for the Fedora builds. I dont have any other distros to validate against. However, adding -lstdc++ to the check_lib_cpp line for taglib corrected the detect issue for me and had no other build issues.

comment:2 Changed 7 years ago by paulh

Can you please paste the last 20 or 30 lines from the config.ep of a failed run of configure? I'd like to see what the actual error is.

comment:3 Changed 7 years ago by ramccor@…

Do you still require it? Your part3 change now corrects it for me.

comment:4 Changed 7 years ago by paulh

The Fedora buildbots are happy now thanks so it's not necessary but it would still be useful to see what the error was because the clang and icc buildbots are failing in a similar way and probably need a similar fix. I don't have access to any of the buildbots so can't get the config.ep to see what the problem is.

comment:5 Changed 7 years ago by Raymond Wagner

Owner: changed from beirdo to paulh
Status: newassigned
Summary: TagLib detection needs -lstdc++ (configure script failure)MythTV will not configure due to issues with TagLib

comment:6 Changed 7 years ago by km@…

I submitted 11511 for Ubuntu 13.04. Adding --extra-libs=-lstdc++ to configure works around the problem.

comment:7 Changed 7 years ago by paulh

Resolution: Fixed
Status: assignedclosed

This should be fixed now.

The clang buildbot was failing because TagLib? was not installed.

The icc buildbot was failing because of an upstream bug documented here https://bugs.kde.org/show_bug.cgi?id=139190

comment:8 Changed 7 years ago by ramccor@…

Since you request what the system previously did, I undid the your addition of -lstdc++ and it yielded very similar results to the ubuntu output...

g++ -D_ISOC99_SOURCE -D_POSIX_C_SOURCE=200112 -D_FILE_OFFSET_BITS=64 -D_LARGEFILE_SOURCE -D_POSIX_C_SOURCE=200112 -D_XOPEN_SOURCE=600 -DPIC -I/usr/include -c -o /tmp/mythtv_conf.ezA4aR3Q.o /tmp/mythtv_conf.udacPGzO.cpp gcc -Wl,--as-needed -I/usr/include -o /tmp/mythtv_conf.FGu69goG /tmp/mythtv_conf.ezA4aR3Q.o -ltag -luuid -pthread -lbz2 -lz -lrt /usr/bin/ld: /tmp/mythtv_conf.ezA4aR3Q.o: undefined reference to symbol 'std::ios_base::Init::~Init()@@GLIBCXX_3.4' /usr/bin/ld: note: 'std::ios_base::Init::~Init()@@GLIBCXX_3.4' is defined in DSO /usr/lib64/libstdc++.so.6 so try adding it to the linker command line /usr/lib64/libstdc++.so.6: could not read symbols: Invalid operation collect2: ld returned 1 exit status ERROR: cannot find taglib 1.6 or later.

comment:9 Changed 7 years ago by paulh

Yeah thanks it looks like the same problem. I think we've beaten it into submission :)

comment:10 Changed 7 years ago by Raymond Wagner

Milestone: unknown0.27
Note: See TracTickets for help on using tickets.