Opened 6 years ago

Closed 6 years ago

#11511 closed Bug Report - General (Duplicate)

taglib problem on ubuntu 13.04

Reported by: km@… Owned by:
Priority: minor Milestone: unknown
Component: MythTV - General Version: Master Head
Severity: medium Keywords:
Cc: Ticket locked: no

Description

Configure fails on checking for taglib (although it is present)

check_cxx -I/usr/include -L/usr/lib/x86_64-linux-gnu BEGIN /tmp/mythtv_conf.agdjT4wt.cpp

1 #include <taglib/fileref.h> 2 int main(void) { 3 TagLib::FileRef? obj1; 4 return 0; }

END /tmp/mythtv_conf.agdjT4wt.cpp g++ -D_ISOC99_SOURCE -D_POSIX_C_SOURCE=200112 -D_FILE_OFFSET_BITS=64 -D_LARGEFILE_SOURCE -D_POSIX_C_SOURCE=200112 -D_XOPEN_SOURCE=600 -DPIC -I/usr/include -L/usr/lib/x86_64-linux-gnu -c -o /tmp/mythtv_conf.DKgZWF7C.o /tmp/mythtv_conf.agdjT4wt.cpp gcc -Wl,--as-needed -I/usr/include -L/usr/lib/x86_64-linux-gnu -o /tmp/mythtv_conf.tK5Q4qFa /tmp/mythtv_conf.DKgZWF7C.o -ltag -luuid -pthread -lz /usr/bin/ld: /tmp/mythtv_conf.DKgZWF7C.o: undefined reference to symbol '_ZNSt8ios_base4InitD1Ev@@GLIBCXX_3.4' /usr/bin/ld: note: '_ZNSt8ios_base4InitD1Ev@@GLIBCXX_3.4' is defined in DSO /usr/lib/x86_64-linux-gnu/libstdc++.so.6 so try adding it to the linker command line /usr/lib/x86_64-linux-gnu/libstdc++.so.6: could not read symbols: Invalid operation collect2: error: ld returned 1 exit status ERROR: cannot find taglib 1.6 or later.

Attachments (1)

config.ep (175.3 KB) - added by km@… 6 years ago.
config.ep show configure error

Download all attachments as: .zip

Change History (2)

Changed 6 years ago by km@…

Attachment: config.ep added

config.ep show configure error

comment:1 Changed 6 years ago by Raymond Wagner

Resolution: Duplicate
Status: newclosed

Duplicate of #11510

Note: See TracTickets for help on using tickets.