Opened 6 years ago

Closed 6 years ago

#11614 closed Bug Report - General (Works for me)

mythtranscode --honorcutlist Seems to Have Stopped Working

Reported by: ian@… Owned by: stuartm
Priority: major Milestone: 0.26.2
Component: MythTV - General Version: 0.26-fixes
Severity: medium Keywords: mythtranscode cutlist
Cc: Ticket locked: no

Description

Originally posted in users, but got no response. If it's reproducible I think it's a bug.

For several years I have been cutting out commercial in a script using:

/usr/bin/mythtranscode --showprogress --honorcutlist --mpeg2 --infile /media/recordings/mythtv/1019_20130617075700.mpg -o /media/recordings/mythtv/1019_20130617075700.mpg.tmp

The file has a valid cutlist, but no sections of video are removed. This is happening with all files I am transcoding. There are no errors reported when I run the command manually.

ian@mythtv:~$ mythtranscode --version Please attach all output as a file in bug reports. MythTV Version : v0.26.0-171-gbfd2408 MythTV Branch : fixes/0.26 Network Protocol : 75 Library API : 0.26.20130225-1 QT Version : 4.8.1 Options compiled in:

linux profile use_hidesyms using_alsa using_oss using_pulse using_pulseoutput using_backend using_bindings_perl using_bindings_python using_bindings_php using_crystalhd using_dvb using_firewire using_frontend using_hdhomerun using_ceton using_hdpvr using_iptv using_ivtv using_joystick_menu using_libcec using_libcrypto using_libdns_sd using_libxml2 using_lirc using_mheg using_opengl_video using_qtwebkit using_qtscript using_qtdbus using_v4l2 using_x11 using_xrandr using_xv using_bindings_perl using_bindings_python using_bindings_php using_mythtranscode using_opengl using_vaapi using_vdpau using_ffmpeg_threads using_live using_mheg using_libass using_libxml2

Ian.

Attachments (1)

mythtranscode.20130624060455.29056.log (10.5 KB) - added by ian@… 6 years ago.
mythtranscode log file

Download all attachments as: .zip

Change History (12)

comment:1 Changed 6 years ago by stuartm

Milestone: unknown0.27
Owner: set to stuartm
Status: newaccepted

Can you please attach the log from mythtranscode?

comment:2 Changed 6 years ago by ian@…

Log isn't very informative:

mythtv@mythtv:~$ /usr/bin/mythtranscode -v all --showprogress --honorcutlist --mpeg2 --infile /media/recordings/mythtv/1019_20130617075700.mpg  -o /media/recordings/mythtv/1019_20130617075700.mpg.tmp > transcode.txt
mythtv@mythtv:~$ less transcode.txt
2013-06-21 09:48:16.896786 C  mythtranscode version: fixes/0.26 [v0.26.0-175-g7f71e02] www.mythtv.org
2013-06-21 09:48:16.896858 C  Qt version: compile: 4.8.1, runtime: 4.8.1
2013-06-21 09:48:17.699360 E  (old)Settings::ReadSettings(settings.txt) - No such file settings.txt

comment:3 Changed 6 years ago by sphery

This is not a log file. Since mythtranscode, when run interactively, outputs information (such as progress reporting) to stdout, you don't get logging to stdout when running mythtranscode interactively. You need to specify --logpath /path/to/directory on the command line and cannot get log output with a redirect.

comment:4 Changed 6 years ago by ian@…

I have created a log file, but its about 7MByte compressed and Trac will only let me upload files of 2MByte. I can upload it to my web server and provide url for you to download it if that's OK.

comment:5 Changed 6 years ago by stuartm

We don't need a -v all log, at least not to begin with. -v general,file will do for now.

Changed 6 years ago by ian@…

mythtranscode log file

comment:6 Changed 6 years ago by ian@…

OK have now uploaded log file.

comment:7 Changed 6 years ago by Stuart Morgan <smorgan@…>

In 5b306f56a310b3358c75d372e8cbec9d84829189/mythtv:

Allow the use of cutlists with --video and --mpeg2
(cherry picked from commit 59f336996dc3fd27129a806fe480a04de6b9aae5)

Refs #11614

comment:8 Changed 6 years ago by stuartm

Can you please update to the latest 0.26-fixes and try again? If it doesn't work then another log would be appreciated. I've backported a fix for a related issue from 0.27-dev, looking closer it seems like this would also permit the use of the cutlist for recordings when --infile is used.

It's difficult to see how cutlists ever worked with mythtranscode used manually from the command line with --infile instead of --chanid/--starttime, but maybe the breakage occurred when the new command line parsing stuff was added a year or two ago.

comment:9 Changed 6 years ago by Karl Egly

Milestone: 0.270.26.1
Status: acceptedinfoneeded

setting to infoneeded

Ian, does it work now?

comment:10 Changed 6 years ago by Raymond Wagner

Milestone: 0.26.10.26.2

comment:11 Changed 6 years ago by stuartm

Resolution: Works for me
Status: infoneededclosed
Note: See TracTickets for help on using tickets.