Opened 13 years ago

Closed 13 years ago

#1168 closed defect (fixed)

Watch Recordings Focus Jumping

Reported by: stuart@… Owned by: Isaac Richards
Priority: minor Milestone: unknown
Component: mythtv Version: head
Severity: medium Keywords:
Cc: Ticket locked: no

Description

I've noticed in the last week some very strange behaviour in the Watch Recordings screen using current SVN [8789].

I use the category group view and whilst scrolling down the programmes in the 'film' category it suddenly 'jumped' to the first programme in the 'Leisure & Hobbies' category. I can't reproduce this consistently but it happens most times I'm browsing the list.

Also when exiting from watching a recording or the 'Edit Recording Schedule' for a particular recording, it jumps to a different recording in another category. It is not only annoying but I almost deleted the wrong recording by mistake.

I've searched through the changes made to playbackbox but can't see anything obvious myself. Maybe Chris's network code although, someone else said the problem is much older?

Change History (3)

comment:1 Changed 13 years ago by anonymous

Summary: Watch RecordingsWatch Recordings Focus Jumping

comment:2 Changed 13 years ago by tom@…

I have the same problem. My 'Watch Recordings' setting is by Title, and it always seems to jump from the 5th Title group to the 8th Title group. It never does it on any other group that I can tell. What log settings do I need to set to figure out what is happening?

Library API version: 0.19.20060121-2 Source code version: 8797 Options compiled in:

linux debug using_xvmcw using_v4l using_oss using_alsa using_ivtv using_lirc using_x11 using_xv using_dvdnav using_xrandr using_xvmc using_xvmc_vld using_opengl_vsync using_frontend using_backend

Tom

comment:3 Changed 13 years ago by gigem

Resolution: fixed
Status: newclosed

(In [8804]) Changed the Watch Recordings screen to use lower case titles when re-finding the current program after a FillList?.

Fixed #1168

Note: See TracTickets for help on using tickets.