Opened 6 years ago

Closed 6 years ago

Last modified 6 years ago

#11748 closed Bug Report - General (Invalid)

mythtv-setup trying to write to wrong user

Reported by: wayno@… Owned by:
Priority: minor Milestone: unknown
Component: MythTV - General Version: 0.26
Severity: medium Keywords:
Cc: Ticket locked: no

Description

I am following the install directions given here:

http://www.mythtv.org/wiki/User_Manual:Initial_Installation

Except, instead of compiling the mythtv source code, I just apt-getted the binary from the debian repo. I am running 64 bit debian/wheezy on a quadcore machine (amd).

When I exit mythtv-setup as logged in user mythtv, it tries to write the configuration file to user nwayno. Which it can not do, since it does not have permission. I have nuked ~/.mythtv in the mythtv directory.

and tried it again, but the same problem persists.

If I go to user nwayno, and run mythtv-setup from there, it wants to write the configuration file to ~/mythtv/.mythtv/ (just the opposite location from running mythtv-setup when logged in as user mythtv)

I thought nuking ~/.mythtv would start me over on the mythtv-setup, but it did not. What am I doing wrong?

I have a wintv pvr-950q.

I am a novice on mythtv, but NOT a novice to Linux.

Wayno www.pkill-9.com

Attachments (2)

mythtv.png (187.4 KB) - added by wayno@… 6 years ago.
mythtv-setup logged in as mythtv, trying to write configuration file to wrong user.
storage_directory.png (21.0 KB) - added by wayno@… 6 years ago.
Correct storage directory set, but still wants to write .test file to another directory.

Download all attachments as: .zip

Change History (12)

Changed 6 years ago by wayno@…

Attachment: mythtv.png added

mythtv-setup logged in as mythtv, trying to write configuration file to wrong user.

comment:1 Changed 6 years ago by wayno@…

I created a new user and tried running mythtv-setup, and it still wants to write to /home/nwayno instead of the correct directory.

So the problem exists OUTSIDE the local user directory. I nuked /etc/mythtv to no avail.

Why is it trying to write the configuration file for mythtv-setup to my home directory, instead of the directory it is running in?

Hmmm.

comment:2 Changed 6 years ago by Raymond Wagner

Priority: majorminor
Status: newinfoneeded_new

This doesn't sound like a MythTV problem. Are you sure you're actually running mythtv-setup and not some wrapper script? What is the environment in which you're trying to run the application (post the output of env)?

comment:3 Changed 6 years ago by Raymond Wagner

Resolution: Invalid
Status: infoneeded_newclosed

Scratch that. Looking at the image, it's testing whether it can write to that directory because you specifically told it to. You configured that as a recording directory.

comment:4 Changed 6 years ago by wayno@…

Resolution: Invalid
Status: closednew

How/where would I correct the information?

comment:5 Changed 6 years ago by Raymond Wagner

Resolution: Invalid
Status: newclosed

You configured the recording directory in the "Storage Directories" section of mythtv-setup. You need to clear it in the same location. That error was produced by a sanity check, meant to ensure MythTV could write to the directories you had defined. Please seek further assistance on the IRC channel or the mailing list.

Changed 6 years ago by wayno@…

Attachment: storage_directory.png added

Correct storage directory set, but still wants to write .test file to another directory.

comment:6 Changed 6 years ago by Raymond Wagner

Did you remove the previous definition, or just add a new one? You can tell MythTV to record to multiple directories.

comment:7 Changed 6 years ago by wayno@…

The previous definition was the same as the new one I added. Even creating a brand new account, and trying it on that, it still wanted to write to the wrong directory.

I don't know how to delete the previous definition. There does NOT seem to be anyway to do that.

The problem is somewhere OUTSIDE the users directory. I would have thought that creating a new user would have solved the issue. It did not.

Wayno

comment:8 Changed 6 years ago by Raymond Wagner

You delete storage directories with the 'd' key. MythTV only has an emergency fallback storage directory if none others are defined, that location never gets stored back to the database, and is in the current user's home directory.

I see no indication that this is a fault in the program, merely a user configuration issue. Please continue this on the mailing list or IRC channel.

comment:9 Changed 6 years ago by wayno@…

You are correct in saying hat it is a user configuration error. The issue is I do NOT know how to fix it. The problem exists OUTSIDE the user directory.

A brand new account, had the exact same issues. Even deleting the file (as suggested above -- thank you!) did not resolve the issues.

What service/channel is the IRC help group?

Wayno

comment:10 Changed 6 years ago by Raymond Wagner

irc.freenode.net, #mythtv-users

Note: See TracTickets for help on using tickets.