Opened 6 years ago

Closed 6 years ago

Last modified 6 years ago

#11749 closed Bug Report - General (Fixed)

Mythmusic indicates wrong track playing

Reported by: stuartm Owned by: paulh
Priority: minor Milestone: 0.27
Component: Plugin - MythMusic Version: Master Head
Severity: medium Keywords:
Cc: Ticket locked: no

Description

  1. Populate the default playlist, in this example I used 'All tracks' with a random shuffle then start it playing.
  2. Return to the playlist editor while it is playing and re-populate the playlist, again by selecting 'All tracks', choose to replace existing tracks.
  3. The same track continues to play, but the current playlist shows an entirely different track is playing.

It appears to show the metadata associated with the particular position in the track list and if the currently playing track moves position within the list it displays the wrong metadata.

Change History (6)

comment:1 Changed 6 years ago by paulh

Owner: set to paulh
Status: newassigned

comment:2 Changed 6 years ago by Paul Harrison <pharrison@…>

In 22748971d3652bf1da4f26f9fcbcc73ec7d10e53/mythtv:

MythMusic: Refactor the musicmetadata handling in the DecoderHandler?

  • Move both the metadata and url storage to DecoderHandler?.
  • Copy the metadata don't store a pointer to it.
  • Make the copy accessible from outside the DecoderHandler?.

Refs #11749.

comment:3 Changed 6 years ago by Paul Harrison <pharrison@…>

In d246e96ccae248e7922bdde6d67abee75dddd157/mythtv:

MusicPlayer?: sanity check the current track after a playlist change

Refs #11749.

comment:4 Changed 6 years ago by Paul Harrison <pharrison@…>

In 2abb60abf05e90c1d580ffe28289b0c162102b33/mythtv:

MythMusic: make sure the current track is correct after shuffling the tracks

Refs #11749.

comment:5 Changed 6 years ago by paulh

Resolution: Fixed
Status: assignedclosed

This seems to be fixed by 2abb60abf0 and d246e96cca

comment:6 Changed 6 years ago by stuartm

Confirmed fixed.

Note: See TracTickets for help on using tickets.