Modify
Warning Please read the Ticket HowTo before creating or commenting on a ticket. Failure to do so may cause your ticket to be rejected or result in a slower response.

Opened 8 months ago

Closed 8 months ago

Last modified 8 months ago

#11753 closed Bug Report - General (fixed)

Dvr/AddRecordSchedule does not work

Reported by: robert.mcnamara@… Owned by: David Engel <dengel@…>
Priority: minor Milestone: 0.27
Component: MythTV - Services API - Backend Version: Unspecified
Severity: medium Keywords:
Cc: Ticket locked: no

Description

The reworked AddRecordSchedule? does not work (and as near as I can tell never has). RecordingRule::isValid is called on the recording rule constructed, but the rule's start and end times and dates are never set. Thus, the duration will always be 0 and isValid will return false. Presumably adding (to Dvr::AddRecordSchedule?):

rule.m_startdate = recstartts.date();
rule.m_starttime = recstartts.time();

rule.m_enddate = recendts.date();
rule.m_endtime = recendts.time();

Will cause this to function as expected.

On an slightly related note, It's a serious bummer to have existing API calls reworked like this rather than replaced and the old ones deprecated-- anyone who has written a client against the existing API is in for a rude awakening when .27 is released.

Attachments (0)

Change History (6)

comment:1 Changed 8 months ago by robert.mcnamara@…

Ref #11495

comment:2 Changed 8 months ago by David Engel <dengel@…>

  • Owner set to David Engel <dengel@…>
  • Resolution set to fixed
  • Status changed from new to closed

In f64d715b30ca7a52359855e00d4d842487ba6dfa/mythtv:

Fix DVR::AddRecordSchedule?() to save the start/end times.

Fixes #11753

comment:3 Changed 8 months ago by gigem

The services API is still very immature and subject to change between MythTV versions. I expect it will remain that way until we begin to use the API ourselves and have a well defined policy and method for providing backward compatibility. In the case of AddRecordSchedule?(), the old version was broken by design and was not something I wanted to keep around.

comment:4 Changed 8 months ago by robert.mcnamara@…

  • Resolution fixed deleted
  • Status changed from closed to new

With the above resolved, AddRecordSchedule? still does not work. It does not set the ChanId? in the recording rule and thus isValid fails because the chanId is invalid.

comment:5 Changed 8 months ago by David Engel <dengel@…>

  • Resolution set to fixed
  • Status changed from new to closed

In 763c7caff6d05e36064765de1133e51cf1a5ec0e/mythtv:

fix more DVR service issues.

I could have sworn I'd tested this all better, but thinking back, I
think I mainly focused on recurring rules with UpdateRecordSchedule?()
and assumed AddRecordSchedule?() also worked since they are almost
identical.

Fixes #11753

comment:6 Changed 8 months ago by dekarl

  • Milestone changed from unknown to 0.27

Add Comment

Modify Ticket

Action
as closed .
The resolution will be deleted. Next status will be 'new'.
Author


E-mail address and user name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.