Opened 6 years ago

Closed 6 years ago

Last modified 6 years ago

#11785 closed Bug Report - General (Fixed)

Archive Utilities 'Play Created DVD' uses machine hostname, should use frontend identifier

Reported by: J.Pilk@… Owned by:
Priority: minor Milestone: 0.27
Component: Plugin - MythArchive Version: 0.26-fixes
Severity: medium Keywords:
Cc: Ticket locked: no

Description

My understanding of this is still somewhat hazy, but I recently unset the 'Backend override' which was apparently preventing removal of some titles from the Videos list on what is now a standalone FE/BE box. After doing this, attempts to 'Play Created DVD' falsely claimed that no DVD had been successfully created. saveSettings() in mythburn.py correctly uses the frontend identifier to record Success. Resetting the frontend identifier to the machine hostname allows playback. I think they are intended to be independent.

IIRC I originally used the identifier because my ISP used to take control of the hostname. I don't see that now.

Change History (8)

comment:1 Changed 6 years ago by paulh

I'm having a hard time understanding what the problem is here. What exactly was the order you did things? That could be the crucial if you created the DVD under one hostname/frontend identifier and tried to test play the DVD under another the setting used to flag success wont be there for the new hostname.

comment:2 Changed 6 years ago by J.Pilk@…

The success flag is written using the frontend identifier; it's read using the hostname. If they don't match, it doesn't play. After I unset the backend override I only had success when these two names were the same.

I think the flag should be read using the LocalHostName?. But at present config.xml has two lines defining that. It's unfortunate that the names are so similar. The current configuration works but I don't think it's reflected in this file snippet.

I haven't rebooted or restarted mythbackend since quitting frontend setup.

<MythFrontend>

<DefaultBackend?>

<LocalHostName?>gatewayf12</LocalHostName?> <!-- This is NOT the name now shown in frontend Setup General --> <!-- The DVD played as soon as I quit frontend setup with the name set as below -->

</DefaultBackend?>

</MythFrontend>

</UPnP> <LocalHostName?>gateway12</LocalHostName?> <!-- machine hostname --> <Database>

comment:3 Changed 6 years ago by J.Pilk@…

I was surprised that a DVD created with one identifier was accepted when the identifier was reset identical to the hostname; on reflection I suspect that the success flag it read might have been a relic of a much earlier build with that configuration. The flag /is/ now being reset, and read, with the hostname; but this test-playback ought to work with any other properly set FE identifier, and it doesn't.

comment:4 Changed 6 years ago by sphery

I don't know what's happening with your reported issue, but the config.xml you show, above, is (/very/) corrupt and may be causing problems with your system (possibly even having some relationship to this issue). Remove the entire config.xml and run mythfrontend or mythtv-setup with the -p argument to let it prompt you for information so it can create a new one, or edit yours to use the proper format for current MythTV, as shown at https://github.com/MythTV/mythtv/blob/fixes/0.26/mythtv/contrib/config_files/config.xml

comment:5 Changed 6 years ago by J.Pilk@…

Yes, I've been trying to relate that example to mine. and to your posts here

http://www.gossamer-threads.com/lists/mythtv/users/527187#527187

and here

http://www.gossamer-threads.com/lists/mythtv/users/538900#538900

I now have two instances of LocalHostName?, both identical to the FE/BE hostname, and a few strangenesses seem to have gone away. I'll come back to it, and your suggestions above, ASAP.

comment:6 Changed 6 years ago by paulh

Component: MythTV - GeneralPlugin - MythArchive
Milestone: unknown0.27
Resolution: Fixed
Status: newclosed

This was likely fixed by [5774843c11] which was preventing the script saving the success flag using the LocalHostName? if it was set in config.xml.

comment:7 Changed 6 years ago by J.Pilk@…

Good. After mdean's comment 4 and exchanges of posts about my config.xml, it has been reworked. I now have a choice of running with either the real hostname or LocalHostName?; I confirm that with my current build the Success flag is always set with the real hostname. That's not quite what I said above but the end result is similar :-) Thanks.

comment:8 Changed 6 years ago by J.Pilk@…

I confirm that, with http://code.mythtv.org/trac/changeset/5774843c11/mythtv in place, mythburn.py now uses the LocalHostName? defined in config.xml, and the test player reads the Success flag and works. Thanks again.

Note: See TracTickets for help on using tickets.