Opened 14 years ago

Closed 14 years ago

#118 closed defect (invalid)

backend not sending replies to commands

Reported by: torbjorn.jansson@… Owned by: Isaac Richards
Priority: minor Milestone: unknown
Component: mythtv Version: head
Severity: medium Keywords:
Cc: Ticket locked: no

Description

Sometimes the backend don't send any response to commands sent to it. i've seen this several times, fortunately it doesn't happen very often.

The last time it happend was when i by mistake (actualy it was caused by the "configure --previous" problem) compiled the backend without dvb support.

the backend complaind at startup with:

2005-07-17 23:28:05.454 ERROR: DVB Card configured on 0, but MythTV was not compiled
with DVB support. Please, recompile MythTV with DVB support
or remove the card from configuration and restart MythTV.

After that message i can reproduce it easily.
At one time it happend right from the begining during the protocol version handshake, and another time protocol handshake worked but the next command (QUERY_RECORDER SPAWN_LIVETV) didn't get any response.

Change History (1)

comment:1 Changed 14 years ago by danielk

Resolution: invalid
Status: newclosed

The three problems described are all different problems.

The first is a user error, fixed by following the instructions MythTV provides.

The second sounds like it might be an actual problem, but it is not really solveable until it is reproduced with network logging on the backends and frontends.

The third is another potential problem, but one requiring the same logs to solve. And it may already be solved in current CVS since there was a bug in LiveTV startup when a recorder was already active that I fixed yesterday.

Note: See TracTickets for help on using tickets.