Opened 6 years ago

Closed 6 years ago

Last modified 5 years ago

#11831 closed Bug Report - Hang/Deadlock (fixed)

Video won't playback after upgrade to 0.27

Reported by: skd5aner@… Owned by: Stuart Morgan <smorgan@…>
Priority: minor Milestone: 0.27.1
Component: MythTV - Video Playback Version: Master Head
Severity: high Keywords:
Cc: Ticket locked: no

Description

After upgrading to 0.27-fixes today (latest RC - v0.27-RC1-47-g783944e), I'm no longer able to playback any video.

When I launch a video or recording (I've tried several different video formats) I get a "Please Wait..." dialog over the menu screen, and nothing else - it just hangs. Occasionally, I'll get a very small blip of audio. The last thing that just repeats over and over at the end of mythfrontend -v playback is:

Decoder mythplayer.cpp:3319 (DecoderGetFrame) - Player(0): Decoder timed out waiting for free video buffers.

Attached is one of my logs with mythfrontend -v playback. I've tried vdpau and ffmpeg standard xv-blit decoding, same results. I've also tried multiple deinterlacers, as well as interlaced and progressive content.

I also tried the version of the nvidia driver that had worked for months on 0.26-fixes as well as upgrading to the latest version of the nvidia driver.

Attachments (2)

mythtv-027videoplaybackfail.txt (56.2 KB) - added by skd5aner@… 6 years ago.
gdb-027fixesRC.txt (98.7 KB) - added by skd5aner <skd5aner@…> 6 years ago.

Download all attachments as: .zip

Change History (9)

Changed 6 years ago by skd5aner@…

comment:1 Changed 6 years ago by stuartm

Status: newinfoneeded_new

There does appear to be a driver problem here, I suspect it's not installed or configured properly. Log shows "OpenGL: OpenGL is using software rendering" at which point it falls back to using the QT painter.

Can you add the driver versions tried and the output of "nvidia-settings -g" to the ticket? Which distro and version are you using? Is the nvidia driver installed from packages or using their installer?

comment:2 Changed 6 years ago by stuartm

To anyone affected by this issue, for now you can work around it by disabling Interactive TV (MHEG). We are very close to a fix but as no dev can reproduce currently progress has been slowed right down.

comment:3 Changed 6 years ago by Stuart Morgan <smorgan@…>

Owner: set to Stuart Morgan <smorgan@…>
Resolution: fixed
Status: infoneeded_newclosed

In a2aa58124f68f6a87076e61ae1d4d175929fd6fb/mythtv:

Revert "MHEG: Fixes for InteractionChannel? streaming from network URI's"

This broke playback of all videos for a number of people. It seems
like there was probably a deadlock somewhere in the mhi code on
startup. Reverting the whole thing since this has such a serious
impact, but it may be re-applied later when we've identified and fixed
the issue.

Fixes #11831

This reverts commit ea77f42462bd1055578131fb64e1586563db9442.

comment:4 Changed 6 years ago by Stuart Morgan <smorgan@…>

In 5b6f3225b8ec7e2430e6563cbbde6a4c25665433/mythtv:

Revert "MHEG: Fixes for InteractionChannel? streaming from network URI's"

Breaks playback of all video for some people, probably a deadlock in
the MHI code on startup. Will reapply at a later date when we've found
the source of the issue.

Refs #11831

This reverts commit ea77f42462bd1055578131fb64e1586563db9442.

Changed 6 years ago by skd5aner <skd5aner@…>

Attachment: gdb-027fixesRC.txt added

comment:5 Changed 6 years ago by skd5aner <skd5aner@…>

As requested in IRC, a backtrace is now attached for version: v0.27-RC1-47-g783944e. I hit ctrl-C during the hang.

Also, if it helps, I'm running:

  • Ubuntu 12.10 server (not mythbuntu)
  • Stock 3.5.0-40-generic kernel
  • nvidia driver version 325.15 (and 313.30 originally). Installed from their installer script. OpenGL works fine from various tests.

comment:6 Changed 6 years ago by skd5aner <skd5aner@…>

Sorry - to clarify - OpenGL works fine outside of MythTV from various tests. Video Playback did fail with any renderer (Xv, VDPAU, and OpenGL).

comment:7 Changed 5 years ago by Raymond Wagner

Milestone: unknown0.27.1
Note: See TracTickets for help on using tickets.