Opened 6 years ago

Closed 5 years ago

#11836 closed Bug Report - General (Invalid)

0.27 is failing to build on armhf

Reported by: superm1@… Owned by:
Priority: minor Milestone: unknown
Component: MythTV - General Version: Unspecified
Severity: medium Keywords:
Cc: Ticket locked: no

Description

In trying to get 0.27 into Ubuntu, I noticed that the armhf build is not passing.

ccache g++ -c -pipe -D_FILE_OFFSET_BITS=64 -D_LARGEFILE_SOURCE -DPIC -march=armv7-a -DNDEBUG -fomit-frame-pointer -fPIC -pthread -g -Wall -Wpointer-arith -D__STDC_CONSTANT_MACROS -D__STDC_LIMIT_MACROS -fvisibility-inlines-hidden -Wmissing-declarations -Wno-switch -Woverloaded-virtual -funit-at-a-time -I/usr/include/freetype2 -fvisibility=hidden -D_REENTRANT -fPIC -Dusing_libcec -D_GNU_SOURCE -DUSING_LIBCRYPTO -DUSING_LIBASS -DFFTW3_SUPPORT -DUSING_X11 -DUSING_XV -DUSING_VAAPI -DUSING_AIRPLAY -DUSING_MHEG -DUSING_FRONTEND -DUSING_FFMPEG_THREADS -DUSING_ALSA -DUSING_OSS -DUSING_V4L2 -DUSING_LINUX_FIREWIRE -DUSING_FIREWIRE -DUSING_IPTV -DUSING_HDHOMERUN -DUSING_CETON -DUSING_IVTV -DUSING_HDPVR -DUSING_DVB -DUSING_BACKEND -DMTV_API -DQT_SQL_LIB -DQT_XML_LIB -DQT_GUI_LIB -DQT_NETWORK_LIB -DQT_CORE_LIB -DQT_SHARED -I/usr/share/qt4/mkspecs/linux-g++ -I. -I/usr/include/qt4/QtCore -I/usr/include/qt4/QtNetwork -I/usr/include/qt4/QtGui -I/usr/include/qt4/QtXml -I/usr/include/qt4/QtSql -I/usr/include/qt4 -I/usr -I/usr/include/libxml2 -I../../external/qjson/include -I.. -I../.. -I../../external/FFmpeg -I. -I../libmyth -I../libmyth/audio -I../libmythbase -I../libmythdvdnav -Impeg -Ichannelscan -Ivisualisations -Irecorders -Irecorders/dvbdev -Irecorders/rtp -Irecorders/vbitext -I../libmythlivemedia/BasicUsageEnvironment/include -I../libmythlivemedia/BasicUsageEnvironment -I../libmythlivemedia/groupsock/include -I../libmythlivemedia/groupsock -I../libmythlivemedia/liveMedia/include -I../libmythlivemedia/liveMedia -I../libmythlivemedia/UsageEnvironment/include -I../libmythlivemedia/UsageEnvironment -I../libmythbase -I../libmythui -I../libmythupnp -I../libmythservicecontracts -I/usr/include -I../libmythdvdnav -I../../external/libmythbluray -I../../external/libhdhomerun -I. -o DetectLetterbox.o DetectLetterbox.cpp
In file included from openglvideo.h:12:0,
                 from vaapicontext.cpp:1:
../libmythui/mythrender_opengl.h:7:22: fatal error: QGLContext: No such file or directory
 #include <QGLContext>
                      ^
compilation terminated.
make[4]: *** [vaapicontext.o] Error 1

Full log: https://launchpadlibrarian.net/149569035/buildlog_ubuntu-saucy-armhf.mythtv_2%3A0.27.0%2Bfixes.20130907.ac841f0-0ubuntu1_FAILEDTOBUILD.txt.gz

Change History (10)

comment:1 Changed 6 years ago by superm1@…

Disabling VAAPI for the armhf build gets it past this, so it's specific to VAAPI.

comment:2 Changed 5 years ago by xris

Just an FYI that this doesn't seem to be limited to ARM. Happens on my x86_64 Fedora 17 build as well, using the packaging repo rpm build script. Removing --enable-vaapi didn't help, but using the (new?) --disable-vaapi flag did allow the compile to finish... but resulted in a binary that complains of being "not compiled with any useable video output method".

Last edited 5 years ago by xris (previous) (diff)

comment:3 Changed 5 years ago by xris

Seems that this leaves a binary with no access to vdpau, despite the compile saying it was enabled.

comment:4 Changed 5 years ago by xris

Looks like this has something to do with configure not detecting any OpenGL in my system (maybe the same for the arm processor?)

comment:5 Changed 5 years ago by xris

Looks like upgrading to Fedora 19 solved my part of this.

comment:6 Changed 5 years ago by andreaz@…

I still have that issue on my new installed mythbox on gentoo. Exactly the same. OpenGL ist set to no, while ./conigure.

Is that a problem of mythtv or my installation?

comment:7 in reply to:  6 Changed 5 years ago by Jonatan Lindblad

Replying to andreaz@…:

I still have that issue on my new installed mythbox on gentoo. Exactly the same. OpenGL ist set to no, while ./conigure.

Is that a problem of mythtv or my installation?

Another Gentoo user recently had some broken packages that prevented OpenGL detection: http://www.gossamer-threads.com/lists/mythtv/users/561867

comment:8 Changed 5 years ago by ian@…

Just had this problem on my Gentoo system. Turned out the problem originated in the file libgdiplus.pc from libgdiplus-2.10.9 which was causing pkg-config --list-all to bail out early. That prevented QtOpenGL being detected in configure. That meant the include directories weren't added and so the compile failed. Correcting libgdiplus.pc enabled the compile to complete. You can do this by removing the following as it isn't needed.

-L${libjpeg_prefix}/lib

comment:9 Changed 5 years ago by pholmes@…

I too had this issue, however mine occured due to the installation of the nvidia driver. The problem was caused by the symbolic link for the /usr/lib64/libGL.so being broken. Once I fixed the issue, opengl was detected and the compile worked.

comment:10 Changed 5 years ago by stuartm

Resolution: Invalid
Status: newclosed

Original submitters problem is that QT GL headers are missing. Other reporters are seeing packaging issues causing a failure to find installed QT and GL headers and libs.

There doesn't seem to be a MythTV bug here.

Note: See TracTickets for help on using tickets.