Opened 13 years ago

Closed 13 years ago

#1185 closed defect (fixed)

PVR-350: doesn't always clear OSD

Reported by: mythtv.cvs@… Owned by: Isaac Richards
Priority: minor Milestone: 0.20
Component: mythtv Version: head
Severity: medium Keywords:
Cc: Ticket locked: no

Description

The LiveTV menu seems to work perfectly with the 350, except when turning on PiP. Once PiP is on, the menu is not removed, and stays on the screen. It also stays on screen for "Change Active Window" and other options.

I've also noticed that while 350 PiP is on, the upper "browse info" menu will also stay on. I can then clear all these menus by bringing up the "position" at the bottom (by moving forward or back). When this position box is cleared, all the above boxes get cleared at the same time.

This behaviour does not exist in XV mode.

Change History (4)

comment:1 Changed 13 years ago by danielk

Milestone: 0.190.20
Version: head

comment:2 Changed 13 years ago by danielk

(In [8889]) References #1185. Clear OSD when PiP is enabled/disabled.

comment:3 Changed 13 years ago by danielk

Summary: live tv menu is not torn down, using PVR-350 not-xv output, when turning on PIPPVR-350: doesn't always clear OSD

I've fixed the PiP enable/disable OSD clearing issue. But, it looks like there are general problems clearing the OSD when OSD displays are disabled. They aren't always cleared until another OSD display is enabled.

comment:4 Changed 13 years ago by danielk

Resolution: fixed
Status: newclosed

(In [8892]) Fixes #1185.

Forces the OSD surface to actually be cleared when the OSD goes away but the PiP is on screen. When there is no PiP we still just set the global alpha to zero.

This also changes the paint order so that the PiP is painted before the OSD surfaces, this allows the OSD surfaces to show up on top of the PiP window as intended, rather than under it.

Note: See TracTickets for help on using tickets.