Opened 6 years ago

Closed 6 years ago

#11872 closed Bug Report - General (Fixed)

Mythmusic can't play dutch public radio stream

Reported by: mythtv@… Owned by: paulh
Priority: minor Milestone: 0.27.1
Component: Plugin - MythMusic Version: 0.27-fixes
Severity: medium Keywords:
Cc: Ticket locked: yes

Description

I love the new Internet Radio function in Mythmusic. Too bad for some reason it isn't able to play more than a few seconds of the dutch national public radio station 3FM:

http://icecast.omroep.nl/3fm-bb-mp3

The player starts, plays a couple of seconds (less than a minute) and then skips to the next stream.

For what it's worth, the built-in di.fm streams all play flawless, so I suspect no problems with my specific setup or connection.

Change History (11)

comment:1 Changed 6 years ago by paulh

Owner: set to paulh
Status: newassigned

I can reproduce the problem. It seems we fill the buffer but then for some reason the connection is closed so once the buffer drains we assume there's a problem with the stream and move on to the next one.

comment:2 Changed 6 years ago by Mike Thompson <mikebt@…>

Same problem here with Australian radio streams

comment:3 Changed 6 years ago by Karl Egly

Mike, we need your exact MythTV version and the stream URL as entered in MythMusic so we have a chance to try and reproduce the issue and hopefully fix it? I'm looking for this string: MythTV Version : v0.28-pre-634-g4325e19-dirty (e.g. from mythfrontend --version)

comment:4 Changed 6 years ago by Mike Thompson <mikebt@…>

Same problem here with Australian radio streams... MythTV Version : v0.27-109-gcb744f8 (Current version from RPMFusion) URL: http://media.on.net/radio/144.m3u

Myth will play this stream for 48 seconds before exhausting the buffer and jumping to the next stream All loaded streams exhibit the same problem with version 0.27, but worked OK in 0.26

comment:5 Changed 6 years ago by Paul Harrison <pharrison@…>

Resolution: fixed
Status: assignedclosed

In 6ddaba216d8f6a7e178d4acfe6930458fb532d05/mythtv:

MythMusic: fix playback of some radio stations

Make sure the maximum size of the QTCPSocket read buffer is set appropriately.

This seems to throttle the sending of readyRead() signals sent to us from
QTCPSocket better otherwise once we fill our buffer and don't read anything in the
readyRead() slot the QTCPSocket will eventually not send any more signals causing
us to run out of data.

Fixes #11872.

comment:6 Changed 6 years ago by Paul Harrison <pharrison@…>

In 7f548de029ed84870538c87193b8b9f650cf0c5a/mythtv:

MythMusic: fix playback of some radio stations

Make sure the maximum size of the QTCPSocket read buffer is set appropriately.

This seems to throttle the sending of readyRead() signals sent to us from
QTCPSocket better otherwise once we fill our buffer and don't read anything in the
readyRead() slot the QTCPSocket will eventually not send any more signals causing
us to run out of data.

Fixes #11872.

(cherry picked from commit 6ddaba216d8f6a7e178d4acfe6930458fb532d05)

comment:7 Changed 6 years ago by paulh

Milestone: unknown0.27.1

The problem reported in the ticket is fixed and 3FM now works OK but there seems to be a problem with the one Mike reported in that the playlist wont download because of a 301 Moved Permanently error which MythDownloadManager? doesn't seem to handle very well. I think this is a recent regression but can't swear to it.

comment:8 Changed 6 years ago by Mike Thompson <mikebt@…>

Resolution: fixed
Status: closednew

Great, so the ticket is closed without actually being fixed.... Should I now open a new ticket?

comment:9 Changed 6 years ago by stuartm

Resolution: Fixed
Status: newclosed
Ticket locked: set

The problem reported by the original ticket submitter IS fixed. Since you have a different problem you need to open a new ticket.

comment:10 Changed 6 years ago by paulh

Resolution: Fixed
Status: closednew

Mike, You appear to be using 0.27-fixes so it's worth updating and seeing if it works. I think this is a recent regression that could only affect the master branch. Your description in comment 4 suggests you was able to get the playlist OK but was affected by the same bug as the OP which is now fixed.

If you haven't already updated it would be useful just to test again with the version you have with the URL you gave us. If it starts to play and stops then you know the playlist downloaded OK. Then update to latest fixes and try again. If it still works we know only master is affected.

Otherwise it's a completely different issue nothing to do with MythMusic. It's a problem in MythDownloadManager? so yes please open a new ticket.

comment:11 Changed 6 years ago by paulh

Resolution: Fixed
Status: newclosed
Note: See TracTickets for help on using tickets.