Opened 6 years ago

Closed 4 years ago

#11935 closed Bug Report - General (Duplicate)

"Master backend tried to connect back to itself!" when running mythutil --scanvideos

Reported by: andreas.thorp@… Owned by: Raymond Wagner
Priority: minor Milestone: 0.27.7
Component: MythTV - General Version: Master Head
Severity: medium Keywords:
Cc: Stuart Auchterlonie Ticket locked: no

Description

After upgrading to 0.27 the fields related to images in table videometadata has not been correctly updated when running mythutil --scanvideos. coverfile, screenshot, banner and fanart are always empty, even though the images have been downloaded. All the other metadata information seems fine.

I have attached the relevant parts of mythbackend.log when running a scan. After downloading the images there is an error: "ERROR: Master backend tried to connect back to itself!"

If I update the metadata from mythfrontend (Change Video Details / Retrieve Details) everything is working as expected.

Attachments (2)

version.txt (920 bytes) - added by andreas.thorp@… 6 years ago.
mythbackend.log (8.3 KB) - added by andreas.thorp@… 6 years ago.
Mythbackend log when running mythutil --scanvideos

Download all attachments as: .zip

Change History (7)

Changed 6 years ago by andreas.thorp@…

Attachment: version.txt added

Changed 6 years ago by andreas.thorp@…

Attachment: mythbackend.log added

Mythbackend log when running mythutil --scanvideos

comment:1 Changed 6 years ago by Raymond Wagner

Component: MythTV - MythmetadatalookupMythTV - General

It looks like the image downloader is trying to push the file to a remote storage directory, rather than storing locally, and connecting back to itself.

comment:2 Changed 6 years ago by mythtv-dev@…

Not a hugely useful workaround admittedly, but if you update a single show using the frontend, then use the "Retrieve all details", it will update artwork that is needed for all the others.

comment:3 Changed 6 years ago by Raymond Wagner

Owner: set to Raymond Wagner
Status: newaccepted

comment:4 Changed 5 years ago by Stuart Auchterlonie

Cc: Stuart Auchterlonie added

I'm seeing this too

comment:5 Changed 4 years ago by Jonatan Lindblad

Milestone: unknown0.27.7
Resolution: Duplicate
Status: acceptedclosed

Most likely a duplicate of #10500 which was fixed by 1d4d102 in master, 9fc0d18 in fixes/0.28, and d8dc0e7 in fixes/0.27.

Note: See TracTickets for help on using tickets.