Opened 6 years ago

Closed 5 years ago

#11960 closed Bug Report - General (Duplicate)

Live TV Fails to switch to Analog tuner after digital tuner used

Reported by: cube1@… Owned by:
Priority: minor Milestone: unknown
Component: MythTV - General Version: 0.27-fixes
Severity: medium Keywords: LiveTV Analog Digital Tuner
Cc: Ticket locked: no

Description

Capture Card: Hauppauge HVR-2250

Something which (with some fussing) worked OK under mythtv 0.25 is failing under 0.27 (mythbuntu 12.04.3, then upgraded to MythTV 0.27)

That it worked under MythTV 0.25 should deal with questions such as whether I have the right firmware, drivrs, etc. (I hope)

If I have a configuration with a single analog tuner, it works fine. If I have a configuration with a single digital tuner, it works fine.

If I have a configuration with both (whether I point them at the same tuner of the two on this card, or use different ones), I can tune analog OK the first time, but once I have tuned to a digital station, if I then go back and try to tune on the analog tuner, the front end goes black, and then eventually responds with a message which is approximately (sorry, but it is a real hassle to recreate the message yet again) "No A/V Decoder". It appears that in these cases the live TV ring buffer file does not get created on the backend.

The digital side is set to No EIT and open on demand (that was necessary to make it work OK under 0.25, and seems to still be necessary under 0.27, or ones gets a "blue screen")

The message in the frontend log reads:

CoreContext? ringbuffer.cpp:1035 (WaitForReadsAllowed?) RingBuf?(/video1/livetv/5005_20131127225009.mpg): Taking too long to be allowed to read.. Nov 27 16:50:11 mythfrontend.real: last message repeated 5 times Nov 27 16:50:11 mythtemp mythfrontend.real: mythfrontend[5223]: E CoreContext? mythplayer.cpp:963 (OpenFile?) Player(0): Couldn't find an A/V decoder for: '/video1/livetv/5005_20131127225009.mpg' Nov 27 16:50:11 mythtemp mythfrontend.real: mythfrontend[5223]: E CoreContext? mythplayer.cpp:2768 (StartPlaying?) Player(0): Unable to open video file.

The backend log from the same timeframe reds

channame(WMTV) startts(Wed Nov 27 22:30:00 2013) endts(Wed Nov 27 23:00:00 2013)#012 recstartts(Wed Nov 27 22:50:08 2013) recendts(Wed Nov 27 23:00:00 2013)#012 title(Jeopardy!)): recording already exists... Nov 27 16:50:11 mythtemp mythbackend: mythbackend[5193]: W DeviceReadBuffer? recorders/DeviceReadBuffer.cpp:555 (Poll) DevRdB(/dev/video0): Poll took an unusually long time 2502 ms Nov 27 16:50:11 mythtemp mythbackend: mythbackend[5193]: I TVRecEvent tv_rec.cpp:1048 (HandleStateChange?) TVRec[9]: Changing from WatchingLiveTV to None

(More of log attached as file)

At the very least, the message from the front-end is misrepresenting the problem.

Attachments (4)

mythbackend.log (14.0 KB) - added by cube1@… 6 years ago.
MythTV Backend Log around time of error.
mythbackend-version.txt (918 bytes) - added by cube1@… 6 years ago.
mytbackend --version output
mythfrontend.log (20.2 KB) - added by cube1@… 6 years ago.
MythTV Front End Log around the time of the error
mythfrontend-version.txt (918 bytes) - added by cube1@… 6 years ago.
mythfrontend --version output

Download all attachments as: .zip

Change History (7)

Changed 6 years ago by cube1@…

Attachment: mythbackend.log added

MythTV Backend Log around time of error.

Changed 6 years ago by cube1@…

Attachment: mythbackend-version.txt added

mytbackend --version output

Changed 6 years ago by cube1@…

Attachment: mythfrontend.log added

MythTV Front End Log around the time of the error

Changed 6 years ago by cube1@…

Attachment: mythfrontend-version.txt added

mythfrontend --version output

comment:1 Changed 6 years ago by cube1@…

Was working with this and that, trying to find a workaround, and in the process regenerated the front end message, which is, to be precise, "Could not find an A/V decoder".

comment:2 Changed 6 years ago by kb9vqf@…

I am seeing this exact problem on a pair of Hauppauge analog/digital tuners with myth0.27-fixes. In my case, however, the frontend crashes most of the time instead of returning with an error message.

comment:3 Changed 5 years ago by paulh

Resolution: Duplicate
Status: newclosed

Duplicate of #11961

Note: See TracTickets for help on using tickets.