Opened 5 years ago

Closed 4 years ago

Last modified 4 years ago

#11970 closed Patch - Bug Fix (fixed)

[PATCH] Improve mythweb handling of This Channel filter

Reported by: Karl Newman <SiliconFiend@…> Owned by: Rob Smith
Priority: minor Milestone: 0.28
Component: Plugin - MythWeb Version: Master Head
Severity: medium Keywords:
Cc: Ticket locked: no

Description

Currently mythweb sets the channel to -1 when loading (via recordid) an existing recording rule for editing of type "Any Time on Any Channel". However, this causes problems if the "This Channel" filter is set (or if it is ever desired to be set in the future)--it will nullify the rule when it is saved because the channel will be invalid. The attached patch fixes this (preserves the channel info for "Any Time on Any Channel") and also improves the channel information display on the Schedules overview page. It now will show the channel number if the "This Channel" filter is set.

Attachments (1)

mythweb-schedule-channel.patch (3.1 KB) - added by Karl Newman <SiliconFiend@…> 5 years ago.
Fix mythweb's schedule editor for This Channel filter

Download all attachments as: .zip

Change History (8)

Changed 5 years ago by Karl Newman <SiliconFiend@…>

Fix mythweb's schedule editor for This Channel filter

comment:1 Changed 4 years ago by Rob Smith <kormoc@…>

Resolution: fixed
Status: newclosed

In 0994985c80373b1a45963974558bf0eeb66a046e/mythweb:

Fixes #11970, this merges a patch by Karl Newman to Improve mythweb handling of This Channel filter

comment:2 Changed 4 years ago by setnes@…

Unfortunately this patch requires ALL scheduled recordings for a given channel to be set to "This Channel" before ANY of the recordings for that channel will be listed with the correct channel information on the overview page.

To say it a different way... If any of the recordings associated with a given channel do NOT have the "This Channel" filter set, then ALL of the recordings for that particular channel will be displayed with "[Any]"... regardless of the "This Channel" filter being set.

This is close, but not quite right yet.

comment:3 Changed 4 years ago by Karl Newman <SiliconFiend@…>

If you originally implemented your recording schedules (or edited them) using an earlier version of MythWeb, that may have lost the channel information. That's part of what this patch is intended to fix, but you would have to re-create your schedules to get the channel information back.

comment:4 Changed 4 years ago by setnes@…

These entries have the channel information. I have verified in the record table. Let me try to explain the symptom of this patch with an example.

Let's say we have four shows that air on the same channel scheduled to record. All four shows are set to "Record at any time on any channel." If all four schedules also have the "This channel" filter enabled, the summary will correctly show the channel instead of "[ Any ]". If one of the four schedules does not have the "This channel" filter enabled, but the other three do, NONE of the schedules will display the channel information on the summary page. Instead they will all have "[ Any ]" displayed. The desired behavior would be for the three records that have the filter enabled to display the channel and only the one record that does not have it enabled should show "[ Any ]".

I hope this makes sense. It's a bit hard to explain. :)

comment:5 Changed 4 years ago by Karl Newman <SiliconFiend@…>

I understand, and I've been able to reproduce it. I was hoping it was a problem on your end... Apparently the schedules share a channel object so the last one to be loaded "wins". I tried to isolate them and use an empty channel object for the "Any" channel schedules, but it doesn't seem to be working. I'll keep poking at it for a little bit.

comment:6 Changed 4 years ago by Karl Newman <SiliconFiend@…>

Fixed it. It was exactly as I thought, a shared channel object where the "Any" schedules were clobbering any later schedules with the same chanid. My testing was complicated because I didn't realize that one of the pair of schedules I was testing with actually DID have the "This Channel" filter set. New patch in new ticket #12276. As part of this patch it also fixes another related bug where an empty channel was supposed to be set to a blank channel object, but because it used = instead of =& it was not actually working.

comment:7 Changed 4 years ago by paulh

Milestone: unknown0.28
Version: UnspecifiedMaster Head
Note: See TracTickets for help on using tickets.