Opened 5 years ago

Closed 5 years ago

#12037 closed Bug Report - General (Fixed)

Submit H/W profile fails with http error 500

Reported by: faginbagin <mythtv@…> Owned by: Karl Egly
Priority: minor Milestone: unknown
Component: MythTV - General Version: 0.27-fixes
Severity: medium Keywords: hardware profile
Cc: Ticket locked: no

Description

Every time I try to submit a hardware profile on any of my machines it fails with the error: Encountered a problem while submitting your profile. So I looked more closely at the script used to submit hardware profiles and tried this command:

/usr/share/mythtv/hardwareprofile/sendProfile.py -d --submitOnly -a >send.out 2>send.err

When the smolt server isn't functioning properly, I get a 503 error code. But I tried it tonight when http://smolt.mythtv.org actually looked functional and got this written to send.err (stderr):

Error contacting Server: HTTP Error 500: Internal error

The error occured at Jan 28 2014, 23:16 EST, in case the date & time help you locate something in the web site's log files. I am also attaching send.out (stdout).

Whatever the root cause, I suspect it's the reason so little information has been collected from 0.27 users.

Attachments (1)

send.out (8.1 KB) - added by faginbagin <mythtv@…> 5 years ago.
Stdout from sendProfile.py

Download all attachments as: .zip

Change History (5)

Changed 5 years ago by faginbagin <mythtv@…>

Attachment: send.out added

Stdout from sendProfile.py

comment:1 Changed 5 years ago by Karl Egly

Owner: set to Raymond Wagner
Status: newassigned

I see "country: null" in your attachment. I've added a dirty hack to master to see if that is the culprit, can you try that on fixes/0.27? [de17fc4ab4] and [6c1f811d61]

comment:2 Changed 5 years ago by faginbagin <mythtv@…>

I patched /usr/share/mythtv/hardwareprofile/distros/mythtv_data/data_mythtv.py and re-ran the sendProfile.py command. It worked. I then used mythfrontend to submit my hardware profile. It also worked and I could view my profile from the frontend. Let me know if I can help test a non-dirty hack. I assume I would need to clobber $HOME/.mythtv/HardwareProfile to test a "clean" environment, and possibly $HOME/.smolt. I also have three frontends and a slave backend I can use for testing.

comment:3 Changed 5 years ago by Karl Egly

Owner: changed from Raymond Wagner to Karl Egly
Status: assignedaccepted

Thanks for getting back with the test result, the hack was committed to fixes/0.27 2014-02-08, closing this as "good enough => fixed". See [b4858000bd] and [6b37da2534].

comment:4 Changed 5 years ago by Karl Egly

Resolution: Fixed
Status: acceptedclosed
Note: See TracTickets for help on using tickets.