Opened 5 years ago

Closed 5 years ago

#12077 closed Bug Report - General (Invalid)

iptv channel scanner broken after change to MythDownloadManager

Reported by: torbjorn.jansson@… Owned by:
Priority: minor Milestone: unknown
Component: MythTV - Channel Scanner Version: 0.27-fixes
Severity: medium Keywords:
Cc: Ticket locked: no

Description

currently in 0.27-fixes the iptv channel scanner is broken if you specify a http:// url to the m3u file. after a bit of digging in the code the function IPTVChannelFetcher::DownloadPlaylist?() ends up only downloading one single line of data and this completely breaks the channel scanner.

i suspect this commit broke it: https://github.com/MythTV/mythtv/commit/1c8e30b140dd7b314fc1d6134a486893b29d6725 committer also said the change was untested.

now it is tested and doesn't work.

Attachments (1)

12077-playlist.m3u (6.0 KB) - added by Karl Egly 5 years ago.
sample playlist

Download all attachments as: .zip

Change History (5)

Changed 5 years ago by Karl Egly

Attachment: 12077-playlist.m3u added

sample playlist

comment:1 Changed 5 years ago by JYA

Please provide the logs output by mythtv-setup.

I can't reproduce that bug.. working just fine here (fixes/0.27 and master)

comment:2 Changed 5 years ago by JYA

Status: newinfoneeded_new

comment:3 Changed 5 years ago by torbjorn.jansson@…

I've found the problem. the issue was with the url itself, was a case of double encoding the () characters in the url and this confused the script i'm using so it was never able to download the channel list from the dvb box.

if you put an url with % chars in already as videodevice, mythtv will encode it a second time with % chars and then you run into problems.

one thing I did run into is that the videodevice field in the capturecard table is a bit short sometimes.

sorry for the noise

comment:4 Changed 5 years ago by JYA

Resolution: Invalid
Status: infoneeded_newclosed
Note: See TracTickets for help on using tickets.