Opened 5 years ago

Closed 5 years ago

Last modified 5 years ago

#12225 closed Bug Report - General (fixed)

Incorrect recording status in Upcoming Recordings

Reported by: gregorio.gervasio@… Owned by: gigem
Priority: minor Milestone: 0.28
Component: MythTV - General Version: Unspecified
Severity: medium Keywords:
Cc: Ticket locked: no

Description

After a recent upgrade on git master, I started seeing the wrong recording status in mythfrontend "Upcoming Recordings", as well as in "mythbackend --printsched". However, the recordings are made correctly.

For example, printsched shows the following:

2014-07-26 15:42:13.628994 I  --- print list start ---
2014-07-26 15:42:13.640642 I  Today                                  3 KNTV    27 06:00-07:00  5  0  0  A  0 -1
2014-07-26 15:42:13.640703 I  Today                               6003 KNTV-BA 27 06:00-07:00  6  0  0  A  0 -1
2014-07-26 15:42:13.640772 I  Today                               1003 KNTV-DT 27 06:00-07:00  1  0  0  A  0 -1
2014-07-26 15:42:13.640827 I  Today                                703 KNTVDT  27 06:00-07:00  5  3  3  A  F -1

This is incorrect -- the program on channel 5703 is marked 'F' (rsOffLine) even though it is the one that will be recorded. Also, channels 1003 and 6003 should be marked with 'F' since their tuners are offline. Channel 3 is marked as being recorded on tuner 0. In older versions, it would have been marked as 'O' (rsOtherShowing).

Adding some debug output to Scheduler::GetAllPending? (cardid: recstartts recstatus chanid title subtitle) shows the correct recstatus:

2014-07-26 15:42:11.304954 I  GetAllPending (0:  2014-07-27T06:00:00 4 5003 Today, )
2014-07-26 15:42:11.304995 I  GetAllPending (0:  2014-07-27T06:00:00 12 6003 Today, )
2014-07-26 15:42:11.305028 I  GetAllPending (0:  2014-07-27T06:00:00 12 1003 Today, )
2014-07-26 15:42:11.305065 I  GetAllPending (3:  2014-07-27T06:00:00 -1 5703 Today, )

However, similar debug output from Scheduler::FillRecordListFromMaster? shows the incorrect status:

2014-07-26 15:42:13.548257 I  FillRecordList (0:  2014-07-27T06:00:00 -1 5003 Today, )
2014-07-26 15:42:13.548275 I  FillRecordList (0:  2014-07-27T06:00:00 -1 6003 Today, )
2014-07-26 15:42:13.548294 I  FillRecordList (0:  2014-07-27T06:00:00 -1 1003 Today, )
2014-07-26 15:42:13.548312 I  FillRecordList (3:  2014-07-27T06:00:00 12 5703 Today, )

I believe the problem is caused by 7f29ae01ef05e39d37ee2dfd4ecd59f8158ca51e, which removed rsOtherShowing. LoadFromScheduler? appears to be incorrectly copying recstatus between programs on different channels that have the same start time (eg. so rsWillRecord is overwritten with rsOffLine).

I have attached a patch to work around the problem by reverting to the behavior prior to the changes which added rsOtherShowing (which is to leave the same program on a different channel with an rsEarlierShowing status).

With this patch, the output of printsched:

2014-07-26 11:16:18.605892 I  --- print list start ---
[...]
2014-07-26 11:16:18.617378 I  Today                                  3 KNTV    27 06:00-07:00  5  0  0  A  E -1
2014-07-26 11:16:18.617435 I  Today                               6003 KNTV-BA 27 06:00-07:00  6  0  0  A  F -1
2014-07-26 11:16:18.617475 I  Today                               1003 KNTV-DT 27 06:00-07:00  1  0  0  A  F -1
2014-07-26 11:16:18.617518 I  Today                                703 KNTVDT  27 06:00-07:00  5  3  3  A  3 -1
[...]

Attachments (1)

0001-Removed-status-override-for-same-record.patch (877 bytes) - added by gregorio.gervasio@… 5 years ago.
Workaround to revert to old recstatus behavior

Download all attachments as: .zip

Change History (5)

Changed 5 years ago by gregorio.gervasio@…

Workaround to revert to old recstatus behavior

comment:1 Changed 5 years ago by gregorio.gervasio@…

Sorry, I missed the relevant printsched header. Here is the incorrect output again:

2014-07-26 15:42:13.629003 I  Title - Subtitle                     Ch Station Day Start  End   S  C  I  T  N Pri
[...]
2014-07-26 15:42:13.640642 I  Today                                  3 KNTV    27 06:00-07:00  5  0  0  A  0 -1
2014-07-26 15:42:13.640703 I  Today                               6003 KNTV-BA 27 06:00-07:00  6  0  0  A  0 -1
2014-07-26 15:42:13.640772 I  Today                               1003 KNTV-DT 27 06:00-07:00  1  0  0  A  0 -1
2014-07-26 15:42:13.640827 I  Today                                703 KNTVDT  27 06:00-07:00  5  3  3  A  F -1
[...]

Here is the output after the workaround patch:

2014-07-26 11:16:18.605896 I  Title - Subtitle                     Ch Station Day Start  End   S  C  I  T  N Pri
[...]
2014-07-26 11:16:18.617378 I  Today                                  3 KNTV    27 06:00-07:00  5  0  0  A  E -1
2014-07-26 11:16:18.617435 I  Today                               6003 KNTV-BA 27 06:00-07:00  6  0  0  A  F -1
2014-07-26 11:16:18.617475 I  Today                               1003 KNTV-DT 27 06:00-07:00  1  0  0  A  F -1
2014-07-26 11:16:18.617518 I  Today                                703 KNTVDT  27 06:00-07:00  5  3  3  A  3 -1
[...]

comment:2 Changed 5 years ago by gigem

Owner: set to gigem
Status: newassigned

comment:3 Changed 5 years ago by David Engel <dengel@…>

Resolution: fixed
Status: assignedclosed

In 0112686c209e0a4811bcc9d93f58c596815882c4/mythtv:

Fix issue with earlier rsOtherShowing removal.

Fixes #12225

comment:4 Changed 5 years ago by paulh

Milestone: unknown0.28
Note: See TracTickets for help on using tickets.