Opened 5 years ago

Closed 5 years ago

#12226 closed Bug Report - General (Fixed)

LiveTV: walking on LiveTV history is broken

Reported by: warpme@… Owned by: JYA
Priority: minor Milestone: unknown
Component: MythTV - Video Playback Version: Master Head
Severity: medium Keywords: LiveTV
Cc: Ticket locked: no

Description

Most likely after https://github.com/MythTV/mythtv/commit/cc927f687995a9620de581894a68935b0780b299 walking LiveTV history seems to be broken. Issue manifest when user skips back and target is within last 10s of previous LiveTV segment. In such case LiveTV jumps to beginning of current segment.

Steeps to reproduce:

-set skip duration to 10sec.

-Start livetv channel

-Watch for 1..2min

-Switch to other channel

-Watch 13–18sec

-Skip back to livetv history back.
-If skip enters previous segment within it's last 10s or so, playback jumps to beginning of current segment.

Attachments (2)

17fps-be.log.zip (23.8 KB) - added by warpme@… 5 years ago.
Logs for 17fps problem
17fps-fe.log.zip (17.2 KB) - added by warpme@… 5 years ago.
17fps logs

Download all attachments as: .zip

Change History (5)

comment:1 Changed 5 years ago by warpme@…

Just some feedback with current master (554bcd6): reverting cc927f6 fixes LiveTV history walking issue but side effect without this commit is that on some HD channels LiveTV playback is with 15–17fps. Pressing for short pause makes playback OK. BE/FE logs attached. Record file sample is on http://warped.homenet.org/ticket12226.mpg

BTW: few weeks ago I done some experiments for trying to fix LiveTV. When I reverted also 195eb07 then 15-17fps problem is fixed....but channel changes is broken. Reverting additionally bfc6b9e makes all OK...but all speedups/smoothness by Lawrence patches in LiveTV gone :-(

Changed 5 years ago by warpme@…

Attachment: 17fps-be.log.zip added

Logs for 17fps problem

Changed 5 years ago by warpme@…

Attachment: 17fps-fe.log.zip added

17fps logs

comment:2 Changed 5 years ago by JYA

the only reason it's smooth is because it just doesn't work, remove all wait and checks.

waits and checks that were there for a reason

comment:3 Changed 5 years ago by JYA

Resolution: Fixed
Status: newclosed
Note: See TracTickets for help on using tickets.