Opened 4 years ago

Closed 4 years ago

#12485 closed Bug Report - General (Duplicate)

IPTV Recorder HLS AES-128 Problem

Reported by: wnhtr2011@… Owned by:
Priority: critical Milestone: unknown
Component: MythTV - General Version: 0.27-fixes
Severity: high Keywords: HLS AES
Cc: Ticket locked: no

Description

I am unable to get the IPTV recorder to work with HLS AES-128 encrypted TS streams (such as this one: http://playertest.longtailvideo.com/adaptive/oceans_aes/oceans_aes.m3u8). The IPTV recorder works fine with unencrypted HLS streams.

I have compiled with the "USING_LIBCRYPTO" option and have libcrypto installed. Additional debugging shows that in HLSReader.cpp, the statement on line 1297 "if (segment.HasKeyPath?())" is returning false even though the stream has the #EXT-KEY-KEY manifest entry that was successfully parsed by myth (and logged as an AES stream in mythtvbackend).

Debugging backend logs also shows that the ts segments are downloading fine, but there is no attempt to download the AES keys.

Change History (1)

comment:1 Changed 4 years ago by Karl Egly

Resolution: Duplicate
Status: newclosed

closing as duplicate of #12486 which has been accepted

Note: See TracTickets for help on using tickets.