Opened 6 years ago

Closed 10 months ago

#12519 closed Bug Report - General (Won't Fix)

No longer functioning "mythfilldatabase"

Reported by: bmlong137@… Owned by: stuartm
Priority: minor Milestone: 31.0
Component: MythTV - Mythfilldatabase Version: Master Head
Severity: medium Keywords:
Cc: Ticket locked: no

Description (last modified by Karl Egly)

Because of an issue with a couple channels, I cleared out my "channel", "program", and related tables. Now when I run "mythfilldatabase" it effectively does nothing. This means my installation is completely shot.

So I downloaded the DD XML using tv_grab_na_dd, stripped out everything but the "station" and "lineup" elements. I ran mythfilldatabase with full debug and found the following. This happened after both "dd_station" and "dd_lineupmap" were populated:

2015-10-05 14:44:26.115590 I  MSqlQuery::exec(DBManager1) SELECT sourceid FROM videosource WHERE lineupid = 'NJ67209:X' <<<< Took 0ms, Returned 1 row(s)
2015-10-05 14:44:26.115624 I  DataDirect: sourceid 8 has lineup type: CableDigital
2015-10-05 14:44:26.115859 I  MSqlQuery::exec(DataDirectCon) INSERT INTO dd_lineup      ( lineupid,  name,  type,  device,  postal) VALUES      ('NJ67209:X', 'Verizon Fios Basking Ridge', 'CableDigital', 'Digital', '07079') <<<< Took 0ms
2015-10-05 14:44:26.116000 I  Grab complete.  Actual data from 2015-10-05T04:00:01Z to 2015-10-19T04:00:01Z (UTC)
2015-10-05 14:44:26.116392 I  MSqlQuery::exec(DBManager1) DELETE FROM settings WHERE value = 'mythfilldatabaseLastRunEnd' AND hostname is NULL; <<<< Took 0ms
2015-10-05 14:44:26.116607 I  MSqlQuery::exec(DBManager1) INSERT INTO settings (value,data ) VALUES ( 'mythfilldatabaseLastRunEnd', '2015-10-05T18:44:26Z' ); <<<< Took 0ms
2015-10-05 14:44:26.116632 I  Main temp tables populated.
2015-10-05 14:44:26.116635 I  Updating MythTV channels.
2015-10-05 14:44:26.117184 I  MSqlQuery::exec(DataDirectCon) TRUNCATE TABLE dd_v_station;
2015-10-05 14:44:26.118541 I  MSqlQuery::exec(DataDirectCon) INSERT INTO dd_v_station      ( stationid,            callsign,         stationname,        affiliate,            fccchannelnumber, channel,            channelMinor) SELECT dd_station.stationid, callsign,         stationname,        affiliate,            fccchannelnumber, channel,            channelMinor FROM dd_station, dd_lineupmap WHERE ((dd_station.stationid  = dd_lineupmap.stationid) AND        (dd_lineupmap.lineupid = '0')) <<<< Took 1ms

Why is "dd_lineupmap.lineupid='0'" a constraint? You can see a few line earlier the lineupid is not '0'. I suspect the issue is here... I assume this has to do with the merging of "cardinput" into "capturecard".

Brian

Change History (5)

comment:1 Changed 6 years ago by bmlong137@…

Here is some better formatting. Sorry, first submission in a LONG time.

2015-10-05 14:44:26.115590 I MSqlQuery::exec(DBManager1) SELECT sourceid FROM videosource WHERE lineupid = 'NJ67209:X' <<<< Took 0ms, Returned 1 row(s)
2015-10-05 14:44:26.115624 I DataDirect?: sourceid 8 has lineup type: CableDigital?
2015-10-05 14:44:26.115859 I MSqlQuery::exec(DataDirectCon?) INSERT INTO dd_lineup ( lineupid, name, type, device, postal) VALUES ('NJ67209:X', 'Verizon Fios Basking Ridge', 'CableDigital?', 'Digital', '07079') <<<< Took 0ms
2015-10-05 14:44:26.116000 I Grab complete. Actual data from 2015-10-05T04:00:01Z to 2015-10-19T04:00:01Z (UTC)
2015-10-05 14:44:26.116392 I MSqlQuery::exec(DBManager1) DELETE FROM settings WHERE value = 'mythfilldatabaseLastRunEnd' AND hostname is NULL; <<<< Took 0ms
2015-10-05 14:44:26.116607 I MSqlQuery::exec(DBManager1) INSERT INTO settings (value,data ) VALUES ( 'mythfilldatabaseLastRunEnd', '2015-10-05T18:44:26Z' ); <<<< Took 0ms
2015-10-05 14:44:26.116632 I Main temp tables populated.
2015-10-05 14:44:26.116635 I Updating MythTV channels.
2015-10-05 14:44:26.117184 I MSqlQuery::exec(DataDirectCon?) TRUNCATE TABLE dd_v_station;
2015-10-05 14:44:26.118541 I MSqlQuery::exec(DataDirectCon?) INSERT INTO dd_v_station ( stationid, callsign, stationname, affiliate, fccchannelnumber, channel, channelMinor) SELECT dd_station.stationid, callsign, stationname, affiliate, fccchannelnumber, channel, channelMinor FROM dd_station, dd_lineupmap WHERE ((dd_station.stationid = dd_lineupmap.stationid) AND (dd_lineupmap.lineupid = '0')) <<<< Took 1ms

comment:2 Changed 6 years ago by bmlong137@…

I found the issue, although I don't know why it is an issue...

I have one source that spans CETON and HDPVR tuners. When I unset the HDPVR source, it worked. I am then able to set the source back on the HDPVR.

comment:3 Changed 5 years ago by Karl Egly

Description: modified (diff)
Milestone: 0.28unknown
Priority: majorminor
Severity: highmedium

Resetting some attributes back to defaults.

The lineupid=0 comes from calling void DataDirectProcessor::UpdateStationViewTable?(QString lineupid). I don't see this being due to the merging of "cardinput" into "capturecard". This is Schedules Direct specific code. I don't see much one of the european developers can do here.

Also fixed the formatting while here.

comment:4 Changed 10 months ago by Gary Buhrmaster

I suspect this ticket can be closed (at least as originally opened). The issue identified was in the DataDirect? (legacy Schedules Direct) code, which has been removed in the latest version of MythTV. If the bug can be reproduced with the XMLTV support a new ticket should likely be opened.

comment:5 Changed 10 months ago by Bill Meek

Milestone: unknown31.0
Resolution: Won't Fix
Status: newclosed
Note: See TracTickets for help on using tickets.