Opened 4 years ago

Closed 3 years ago

Last modified 3 years ago

#12600 closed Bug Report - General (Fixed)

Cannot access backend status from embedded web server

Reported by: Stuart Auchterlonie Owned by: stuartm
Priority: minor Milestone: 29.0
Component: MythTV - Web Frontend Version: Master Head
Severity: medium Keywords:
Cc: Ticket locked: no

Description (last modified by Stuart Auchterlonie)

Attempting to follow the link from the side bar for Information > Backend Status results in no action.

Looking at the web debugger, it's throwing the error

"loadContent: URL(/Status/GetStatusHTML) JSURL(undefined)"

raised from util.qjs:112

Change History (7)

comment:1 Changed 4 years ago by Stuart Auchterlonie

Description: modified (diff)

comment:2 Changed 4 years ago by paulh

The debugger error seems to be a red-herring. The problem is caused by the changes in [eea78ee7] in particular the 'Switch to using an iframe for content' part. Anything that uses

function loadContent(contentURL, jsURL)

to load the content is now failing.

Using

function loadFrontendContent(contentURL)

instead to load the Backend Status works but not sure if that is the correct fix.

Switching back to using a div for 'content' here https://github.com/MythTV/mythtv/blob/master/mythtv/html/backend_index.qsp#L64 also works for the Backend Status page but breaks other stuff so isn't the correct fix.

Hopefully this will point someone in the right direction to fix this properly :)

comment:3 Changed 4 years ago by stuartm

I know how to fix this, I'll get to it before the release.

comment:4 Changed 4 years ago by Stuart Auchterlonie

Milestone: 0.280.29

Moving to 0.29

comment:5 Changed 4 years ago by Stuart Auchterlonie

Milestone: 0.2929.0

Milestone renamed

comment:6 Changed 3 years ago by Stuart Auchterlonie

Resolution: Fixed
Status: newclosed

comment:7 Changed 3 years ago by Stuart Auchterlonie

And cherry picked to fixes/0.28 in [6956ff00feb1e8a1ce137ccbbf6d32354714018b]

Note: See TracTickets for help on using tickets.