Opened 4 years ago

Closed 4 years ago

#12610 closed Bug Report - General (Fixed)

Fixup needed for special IPTV streams

Reported by: bjoernv@… Owned by: Karl Egly
Priority: minor Milestone: 0.28
Component: MythTV - Channel Scanner Version: Master Head
Severity: medium Keywords:
Cc: Ticket locked: no

Description

I tried to setup the IPTV playlist

http://tv.iptv.ink/iptv.ink

according to

https://www.mythtv.org/wiki/User_Manual:Setting_up_HTTP_Live_Streaming_Recorder

No channels are found in MythTV 0.27 and 0.28. Other applications like VLC or the Android App "IPTV" (https://play.google.com/store/apps/details?id=ru.iptvremote.android.iptv) have no problems with this playlist.

Some debugging shows that ./mythtv/libs/libmythtv/channelscan/iptvchannelfetcher.cpp (function parse_chan_info) does not recognize the channel info.

Change History (5)

comment:1 Changed 4 years ago by Karl Egly

Component: MythTV - GeneralMythTV - Channel Scanner
Milestone: 0.28unknown
#EXTINF:0002 tvg-id="daserste.de" group-title="DE Hauptsender" tvg-logo="609281.png", [COLOR gold]Das Erste[/COLOR]
http://api.iptv.ink/pl.m3u8?ch=71565725

Two thoughts

comment:2 Changed 4 years ago by Karl Dietz <dekarl@…>

In 7b8a16520fe700b6de0ff4389b923534b24386db/mythtv:

add another variant of M3U scraping to the IPTV recorder

Refs #12610

comment:3 Changed 4 years ago by Karl Egly

Milestone: unknown0.28
Owner: set to Karl Egly
Status: newaccepted

I located this "channel number in duration field" as intended behavior of a Russian Kodi plug-in, so lets add it. Here's the machine translation from the Russian forum http://forum.kodi.tv/showthread.php?tid=156218&pid=1336794#pid1336794 Can you retest?

comment:4 Changed 4 years ago by Karl Egly

Status: acceptedinfoneeded

comment:5 Changed 4 years ago by Karl Egly

Resolution: Fixed
Status: infoneededclosed

No reply in more then 30 days, closing as fixed. (Even though unverified)

Note: See TracTickets for help on using tickets.