Opened 4 years ago

Closed 4 years ago

#12700 closed Bug Report - General (Duplicate)

Null pointer dereference playing Blu-ray

Reported by: stuartm Owned by: JYA
Priority: blocker Milestone: 0.28
Component: MythTV - Blu-ray Playback Version: Master Head
Severity: high Keywords:
Cc: Ticket locked: no

Description

Thread 1 (Thread 0x7fffdc6567c0 (LWP 15495)):
#0  0x00007ffff4a8648e in MythPlayer::GetDecoder() (this=0x0) at mythplayer.h:275
#1  0x00007ffff4ce5172 in TV::HandleStateChange(PlayerContext*, PlayerContext*) (this=0x1e8a220, mctx=0x1a403e0, ctx=0x1a403e0) at tv_play.cpp:2616
        mainWindow = 0xbafac0
        decName = {static null = {<No data fields>}, d = 0xb9a080}
        __FUNCTION__ = "HandleStateChange"
        __func__ = "HandleStateChange"
        ctxState = kState_None
        desiredNextState = kState_WatchingBD
        ok = false
        lastState = kState_None
        changed = true
        nextState = kState_None
#2  0x00007ffff4ce0d1f in TV::Playback(ProgramInfo const&) (this=0x1e8a220, rcinfo=...) at tv_play.cpp:2175
        mctx = 0x1a403e0
#3  0x00007ffff4cc440d in TV::StartTV(ProgramInfo*, unsigned int, std::vector<ChannelInfo, std::allocator<ChannelInfo> > const&) (tvrec=0x1a52f00, flags=0, selection=std::vector of length 0, capacity 0) at tv_play.cpp:379
        mctx = 0x0
        inPlaylist = false
        initByNetworkCommand = false
        curProgram = 0x1e9ace0
        startLivetvEventSent = false
        __FUNCTION__ = "StartTV"
        __func__ = "StartTV"
        showDialogs = true
        playCompleted = false
        startSysEventSent = false
        playerError = {static null = {<No data fields>}, d = 0x7fffea195d20 <QArrayData::shared_null>}
        allowrerecord = false
        tv = 0x1e8a220
        quitAll = false
        deleterecording = false
#4  0x0000000000458392 in (anonymous namespace)::BookmarkDialog::customEvent(QEvent*) (this=0x1d69270, event=0xd78dc0) at main.cpp:244
        flags = 0
        dce = 0xd78dc0
        buttonnum = 0

Change History (1)

comment:1 Changed 4 years ago by Roger Siddons

Resolution: Duplicate
Status: newclosed

Duplicate of #12709, which will be resolved by #12693

Note: See TracTickets for help on using tickets.