Opened 3 years ago

Closed 3 years ago

#12783 closed Bug Report - General (Fixed)

Live TV channel selected via guide results in "schedule order" being used for tuner priority

Reported by: wdormann@… Owned by: gigem
Priority: minor Milestone: 0.28.1
Component: MythTV - Scheduling Version: 0.27-fixes
Severity: medium Keywords:
Cc: Ticket locked: no

Description

I have a multiple-tuner system running 2:0.27.6+fixes.20160506.114504a-0ubuntu0mythbuntu4 When in "Live TV" mode and the channel is selected via the guide (as opposed to typing in the channel number, or pressing the up or down arrow), the "Schedule Order" priority for the set of tuners is used, rather than the "Live TV" priority.

Steps to reproduce:

  1. On a multi-tuner system, in mythtv-setup configure tuner 1 to have a "Schedule order" of 1, and a "Live TV Order" of 2. See <https://www.mythtv.org/wiki/Setup_Input_Connections>
  2. Configure tuner 2 to have a "Schedule order" of 2, and a "Live TV Order" of 1. This is the recommended behavior to avoid having a scheduled recording preempt a Live TV session.
  3. Start watching "Live TV" via MythTV
  4. Enter the MythTV Program Guide to find a new channel.
  5. Select a new channel via the guide

Actual results: With step 3, tuner 2 is used. With step 5, tuner 1 is used.

Expected results: Tuner 2 is used for all Live TV channel tuning.

In my case, my tuner 1 is an HD-PVR, so it's easy to notice when it's being utilized, as the LED on the front comes on. My second tuner is an HDHR prime, which actually is 3 tuners. But I assume that this should be possible to reproduce with only two tuners. In my case, I have the Live TV Order as 4, 3, 2, 1 and my Scheduled Order as 1,2,3,4

Change History (2)

comment:1 Changed 3 years ago by wdormann@…

This seems to be addressed in 0.28

comment:2 Changed 3 years ago by gigem

Milestone: unknown0.28.1
Resolution: Fixed
Status: newclosed

Thanks for reporting back.

Note: See TracTickets for help on using tickets.