Opened 2 years ago

Last modified 22 months ago

#12841 infoneeded Bug Report - General

IPTV m3u format not working

Reported by: frank@… Owned by: Karl Egly
Priority: major Milestone: unknown
Component: MythTV - Channel Scanner Version: Unspecified
Severity: medium Keywords: m3u iptv
Cc: Ticket locked: no

Description (last modified by Karl Egly)

Hi,

I use an IPTV Server (Kathrein) and produced a m3u playlist using EyeTV. For VLC the list is working fine but freebox in mythtv does not recognize any channels.

So I think that the playlist is in a wrong format. It would be great if you could help me.

Here are some lines of the m3u list:

#EXTM3U
#EXTINF:0,1 Das Erste
http://192.168.0.57/?src=1&msys=dvbs&mtype=qpsk&freq=11836.00&sr=27500&pol=h&fec=34&pids=0,16,17,18,20,101,102,103,104,84,1176,2070,2171,106,105,100,101
#EXTINF:0,2 Das Erste HD
http://192.168.0.57/?src=1&msys=dvbs2&mtype=qpsk&freq=11494.00&sr=22000&pol=h&fec=23&pids=0,16,17,18,20,5102,5104,5106,5101,5105,5100,5101

Thanks,

Frank.

Change History (5)

comment:1 Changed 2 years ago by Karl Egly

Component: MythTV - GeneralMythTV - Channel Scanner
Description: modified (diff)
Owner: set to Karl Egly
Status: newaccepted

comment:2 Changed 2 years ago by Karl Egly

Milestone: 0.27.7unknown

Yes, I think we don't support this variant (just a space between channel number and channel name) right now.

For a SAT>IP device I'd expect the format to be "channel number, full stop, space, channel name" e.g. "1. Das Erste"

Here is the playlist for out unit test for SAT>IP style playlists https://github.com/MythTV/mythtv/blob/fixes/0.28/mythtv/libs/libmythtv/test/test_iptvrecorder/test_iptvrecorder.h#L125-L131

As a quick workaround you can download the playlist and edit the format.

Can you give some details on the IPTV server device and the version of MythTV that you are running?

comment:3 Changed 2 years ago by frank@…

Thank you very much for your answer. I will try to build a playlist on my own as a workaround.

The IPTV Server is a Kathrein EXIP 414. Because this server is not able to serve a M3U list I created this list in "M3U8" Format using EyeTV on MacOS.

Currently I try to use MythTV on MacOS using the latest MacPorts? package including MythTV 0.27

comment:4 Changed 2 years ago by frank@…

I am afraid but I can't get a modified playlist to work. I changed the list to this format

#EXTM3U

#EXTINF:0,1. Das Erste

http://192.168.0.57/?src=1&msys=dvbs&mtype=qpsk&freq=11836.00&sr=27500&pol=h&fec=34&pids=0,16,17,18,20,101,102,103,104,84,1176,2070,2171,106,105,100,101[[BR]]

So the first two lines should now match the parsers expectations but the third line does not. E.g. for the parser it should begin with "rtp..." but mine starts with "http...".

With this format still no senders are found. Any idea for this?

THANKS!

comment:5 Changed 22 months ago by Karl Egly

Status: acceptedinfoneeded

I lost track of this. Can you clarify the version you are running? MPEG-TS over http should work on fixes/0.28

Note: See TracTickets for help on using tickets.