Opened 3 years ago

Closed 2 years ago

Last modified 2 years ago

#12884 closed Bug Report - General (Fixed)

Front end setup screens become inoperable after appearance change

Reported by: Peter Bennett Owned by: stuartm
Priority: minor Milestone: 29.0
Component: MythTV - User Interface Library Version: 0.28.0
Severity: medium Keywords:
Cc: jharbestonus@… Ticket locked: no

Description

If you go into setup for either theme chooser or appearance, and "next" through to the end or select a theme, next time you go into setup the keyboard focus is lost. Using keyboard arrows has no effect. You can click buttons with the mouse but they don't highlight.

A work-around is, if you go through setup for appearance or theme chooser, after finishing the appearance or theme change, exit from frontend and then start frontend again.

This seems to be associated with the fact that the screen is taken down and re-initialized after appearance changes. It is strange that it affects only setup pages and not the main user interface.

This bug is new with 0.28. It happens with all themes, and with all theme painters.

Change History (7)

comment:1 Changed 3 years ago by ctreleaven@…

Dupe of #12857 ?

comment:2 Changed 3 years ago by Peter Bennett

Not a duplicate of #12857 - it is a different situation and not related to OS/X.

comment:3 Changed 2 years ago by Roger Siddons

It could well be related.

Last time I experienced this I noticed that a mouse-click on the screen restored normal operation. Re-initialising the UI causes Myth to lose window focus with no visual cue. (Linux)

Last edited 2 years ago by Roger Siddons (previous) (diff)

comment:4 Changed 2 years ago by Peter Bennett

This problem does not happen with the new setup screens (devel/mythui/settings branch). If we merge that into master we will be able to retire this bug without any further work.

comment:5 Changed 2 years ago by jharbestonus@…

As I recall, I did have similar problems on the Rpi. However I found that the database version mismatch documented in the Raspberry Pi web page setup fixed the problems that I had. I have not had the problem since then.

comment:6 Changed 2 years ago by Peter Bennett

Resolution: Fixed
Status: newclosed

This problem is fixed with the new MythUI setup screens.

See #13046

comment:7 Changed 2 years ago by Stuart Auchterlonie

Milestone: unknown29.0
Note: See TracTickets for help on using tickets.