Opened 3 years ago

Closed 3 years ago

Last modified 3 years ago

#12883 closed Bug Report - General (Duplicate)

NoTrans: SQL Error: Expression #3 of SELECT

Reported by: davekoenig@… Owned by:
Priority: minor Milestone: 0.28.1
Component: Plugin - MythWeb Version: 0.28.0
Severity: medium Keywords:
Cc: Ticket locked: no

Description

datetime: 2016-09-22 21:15:26 (CDT)

errornum: 256

error type: User Error

error string: !NoTrans: SQL Error: Expression #3 of SELECT list is not in GROUP BY clause and contains nonaggregated column 'mythconverg.program.endtime' which is not functionally dependent on columns in GROUP BY clause; this is incompatible with sql_mode=only_full_group_by #1055!!

filename: /usr/share/mythtv/mythweb/classes/Database/Query/mysqlicompat.php

error line: 98

==========================================================================

Backtrace:

file: /usr/share/mythtv/mythweb/classes/Database/Query/mysqlicompat.php line: 98

class:

function: trigger_error

type: args: Array

(

[0] => SQL Error: Expression #3 of SELECT list is not in GROUP BY clause and contains nonaggregated column 'mythconverg.program.endtime' which is not functionally dependent on columns in GROUP BY clause; this is incompatible with sql_mode=only_full_group_by #1055 [1] => 256

)

file: /usr/share/mythtv/mythweb/classes/Database.php line: 261

class: Database_Query_mysqlicompat

function: execute

type: -> args: Array

(

[0] => Array ( )

)

file: /usr/share/mythtv/mythweb/modules/tv/includes/programs.php line: 140

class: Database

function: query

type: -> args: Array

(

[0] => SELECT program.*,

UNIX_TIMESTAMP(program.starttime) AS starttime_unix, UNIX_TIMESTAMP(program.endtime) AS endtime_unix, IFNULL(programrating.system, "") AS rater, IFNULL(programrating.rating, "") AS rating, channel.callsign, channel.channum

FROM program USE INDEX (id_start_end)

LEFT JOIN programrating USING (chanid, starttime) LEFT JOIN channel ON program.chanid = channel.chanid LEFT JOIN credits ON (program.chanid = credits.chanid AND program.starttime = credits.starttime) LEFT JOIN people ON (credits.person = people.person)

WHERE program.chanid='1021' AND (program.endtime > FROM_UNIXTIME('1474596900') AND program.starttime < FROM_UNIXTIME('1474607700') AND program.starttime != program.endtime)

GROUP BY channel.callsign, program.chanid, program.starttime ORDER BY program.starttime )

file: /usr/share/mythtv/mythweb/modules/tv/classes/Channel.php line: 154

class:

function: load_all_program_data

type: args: Array

(

[0] => 1474596900 [1] => 1474607700 [2] => 1021

)

file: /usr/share/mythtv/mythweb/modules/tv/tmpl/default/list_data.php line: 102

class: Channel

function: display_programs

type: -> args: Array

(

[0] => 1474596900 [1] => 1474607700

)

file: /usr/share/mythtv/mythweb/modules/tv/tmpl/default/list.php line: 78

class:

function: require_once

type: args: Array

(

[0] => /usr/share/mythtv/mythweb/modules/tv/tmpl/default/list_data.php

)

file: /usr/share/mythtv/mythweb/modules/tv/list.php line: 45

class:

function: require_once

type: args: Array

(

[0] => /usr/share/mythtv/mythweb/modules/tv/tmpl/default/list.php

)

file: /usr/share/mythtv/mythweb/modules/tv/handler.php line: 82

class:

function: require_once

type: args: Array

(

[0] => /usr/share/mythtv/mythweb/modules/tv/list.php

)

file: /usr/share/mythtv/mythweb/mythweb.php line: 35

class:

function: require_once

type: args: Array

(

[0] => /usr/share/mythtv/mythweb/modules/tv/handler.php

)

==========================================================================

$_SESSION: Array (

[cache_engine] => Cache_Null [stream] => Array

(

[include_user_and_password] =>

)

[prefer_channum] => 1 [recorded_pixmaps] => 1 [guide_favonly] => [timeslot_size] => 300 [num_time_slots] => 36 [timeslot_blocks] => 3 [timeslotbar_skip] => 20 [max_stars] => 4 [star_character] => &#9733; [show_popup_info] => 1 [show_channel_icons] => 1 [sortby_channum] => 1 [recorded_paging] => [genre_colors] => 1 [show_video_covers] => 1 [settings] => Array

(

[screens] => Array

(

[tv] => Array

(

[upcoming recordings] => Array

(

[title] => on [channel] => on [record date] => on [length] => on

)

)

)

[last] => Array

(

[0] => database [1] => settings

)

)

[backend] => Array

(

[192.168.1.195] => Array

(

[proto_version] => Array

(

[last_check_version] => 88 [last_check_time] => 1474596682

)

)

[timezone] => Array

(

[value] => US/Central [last_check_time] => 1474596682

)

)

[language] => English [date_statusbar] => %a %b %e, %Y, %I:%M %p [date_scheduled] => %a %b %e, %Y (%I:%M %p) [date_scheduled_popup] => %a %b %e, %Y [date_recorded] => %a %b %e, %Y (%I:%M %p) [date_search] => %a %b %e, %Y, %I:%M %p [date_listing_key] => %a %b %e, %Y, %I:%M %p [date_listing_jump] => %a %b %e, %Y [date_channel_jump] => %a %b %e, %Y [date_job_status] => %a %b %e, %Y, %I:%M %p [time_format] => %I:%M %p [tv] => Array

(

[last] => Array

(

[0] => list

)

[show_advanced_schedule] => 1

)

[list_time] => 1474596900

)

==========================================================================

$_SERVER: Array (

[REDIRECT_STATUS] => 200 [HTTP_HOST] => 192.168.1.195 [HTTP_CONNECTION] => keep-alive [HTTP_UPGRADE_INSECURE_REQUESTS] => 1 [HTTP_USER_AGENT] => Mozilla/5.0 (Windows NT 6.1; WOW64) AppleWebKit?/537.36 (KHTML, like Gecko) Chrome/53.0.2785.116 Safari/537.36 [HTTP_ACCEPT] => text/html,application/xhtml+xml,application/xml;q=0.9,image/webp,*/*;q=0.8 [HTTP_REFERER] => http://192.168.1.195/mythweb/settings/database [HTTP_ACCEPT_ENCODING] => gzip, deflate, sdch [HTTP_ACCEPT_LANGUAGE] => en-US,en;q=0.8 [HTTP_COOKIE] => mythweb_id=j92uk90g7s1de3h3eald9mh863 [PATH] => /usr/local/sbin:/usr/local/bin:/usr/sbin:/usr/bin:/sbin:/bin [SERVER_SIGNATURE] => <address>Apache/2.4.18 (Ubuntu) Server at 192.168.1.195 Port 80</address>

[SERVER_SOFTWARE] => Apache/2.4.18 (Ubuntu) [SERVER_NAME] => 192.168.1.195 [SERVER_ADDR] => 192.168.1.195 [SERVER_PORT] => 80 [REMOTE_ADDR] => 192.168.1.27 [DOCUMENT_ROOT] => /var/www/html [REQUEST_SCHEME] => http [CONTEXT_PREFIX] => [CONTEXT_DOCUMENT_ROOT] => /var/www/html [SERVER_ADMIN] => webmaster@localhost [SCRIPT_FILENAME] => /var/www/html/mythweb/mythweb.php [REMOTE_PORT] => 49502 [REDIRECT_URL] => /mythweb/tv/list [GATEWAY_INTERFACE] => CGI/1.1 [SERVER_PROTOCOL] => HTTP/1.1 [REQUEST_METHOD] => GET [QUERY_STRING] => [REQUEST_URI] => /tv/list [SCRIPT_NAME] => /mythweb/mythweb.php [PATH_INFO] => /tv/list [PATH_TRANSLATED] => /var/www/html/tv/list [PHP_SELF] => /mythweb/mythweb.php/tv/list [REQUEST_TIME_FLOAT] => 1474596925.984 [REQUEST_TIME] => 1474596925 [STATUS] => 200 [URL] => /mythweb/tv/list [HTTP_X_FORWARDED_PROTO] => [HTTPS] => [HTTP_PORT] => 80

)

==========================================================================

$constant_listuser?: Array (

[ERROR] => 512 [E_ASSERT_ERROR] => 4096 [FATAL] => 256 [PHP_MIN_VERSION] => 5.3 [WARNING] => 1024 [WebDBSchemaVer] => 4 [dupsin_all] => 15 [dupsin_newepisodes] => 16 [dupsin_oldrecorded] => 2 [dupsin_recorded] => 1 [error_email] => [gb] => 1073741824 [hostname] => ubuntu-standard [http_host] => 192.168.1.195 [kb] => 1024 [max_stars] => 4 [mb] => 1048576 [module] => tv [modules_path] => /usr/share/mythtv/mythweb/modules [num_time_slots] => 36 [prefer_channum] => 1 [rectype_always] => 4 [rectype_daily] => 2 [rectype_dontrec] => 8 [rectype_findone] => 6 [rectype_once] => 1 [rectype_override] => 7 [rectype_template] => 11 [rectype_weekly] => 5 [root] => /mythweb/ [root_auth_url] => http://192.168.1.195/mythweb/ [root_url] => http://192.168.1.195/mythweb/ [searchtype_keyword] => 3 [searchtype_manual] => 5 [searchtype_people] => 4 [searchtype_power] => 1 [searchtype_title] => 2 [skin] => default [skin_img_url] => http://192.168.1.195/mythweb/skins/default/img/ [skin_url] => http://192.168.1.195/mythweb/skins/default/ [star_character] => &#9733; [stream_url] => http://192.168.1.195:80//mythweb/ [tb] => 1099511627776 [timeslot_blocks] => 3 [timeslot_size] => 300 [timeslotbar_skip] => 20 [tmpl] => default [tmpl_dir] => modules/tv/tmpl/default/

)

Change History (3)

comment:1 Changed 3 years ago by Stuart Auchterlonie

Component: MythTV - GeneralPlugin - MythWeb
Milestone: unknown0.28.1
Resolution: Duplicate
Status: newclosed
Version: Unspecified0.28.0

Duplicate of #12811. Please try the patch called "MythWeb-SQL_mode_patch.diff​" attached to that ticket. We need some feedback on if it works or not. Please report any feedback to that ticket

Regards Stuart

comment:2 Changed 3 years ago by davekoenig@…

OK, I have file, not the best with Linux, what do I do with it? Can I copy it to SD card in Windows, or do I put on USB drive and copy over in Ubuntu?

comment:3 Changed 3 years ago by sphery

On the (Linux) machine running MythWeb, cd to the MythWeb application root directory (somewhere under your Apache's htdocs directory, probably--the directory that contains classes, includes, and skins directories, among other directories and files) and issue the command:

sudo patch -Np0 -i /path/to/MythWeb-SQL_mode_patch.diff

Then retest the MythWeb pages that were failing. If you get the exact same error, please restart Apache (an easy way to do so is to reboot the MythWeb host) and try again. Thanks for taking the time to test.

Note: See TracTickets for help on using tickets.