Opened 5 years ago

Closed 8 months ago

#13140 closed Bug Report - General (Trac EOL)

mythfrontend startup hangs and does not provide usable error message when MythUIWebBrowser fails to enable plugins due to bad browser plugin

Reported by: Richard Shaw <hobbes1069@…> Owned by:
Priority: minor Milestone: needs_triage
Component: MythTV - General Version: 0.28.1
Severity: medium Keywords:
Cc: Ticket locked: no

Description

Subject mostly says it all, reference RPM Fusion bug for more details:

https://bugzilla.rpmfusion.org/show_bug.cgi?id=4600

Change History (2)

comment:1 Changed 5 years ago by sphery

Summary: mythfrontend does not provide usable error message when it fails to start due to bad pluginmythfrontend startup hangs and does not provide usable error message when MythUIWebBrowser fails to enable plugins due to bad browser plugin

FWIW, these are external, 3rd-party browser plugins being loaded by MythUIWebBrowser when the setting WebBrowserEnablePlugins? is enabled. Based on the RPM Fusion bug, it sounds like frontend startup is hanging and, when interrupted with Ctrl-C, leaves 2 processes that must be killed with kill -KILL. It's not so much that it's "failing to start" and exits with no errors as it's just hanging, right?

Modified the summary/subject to make it a bit more descriptive. I'm not sure whether this should stay filed under MythTV - General or be changed to Plugins/MythBrowser?.

comment:2 Changed 8 months ago by Stuart Auchterlonie

Resolution: Trac EOL
Status: newclosed

We have moved all bug tracking to github [1]

If you continue to have this issue, please open a new issue at github, referencing this ticket.

[1] - https://github.com/MythTV/mythtv/issues

Note: See TracTickets for help on using tickets.