Opened 14 years ago

Closed 13 years ago

#1337 closed defect (fixed)

DVB needs to check for audio in PMT when not recording MHEG.

Reported by: John Pullan <john.pullan@…> Owned by: danielk
Priority: minor Milestone: 0.20
Component: dvb Version: head
Severity: medium Keywords: DVB
Cc: Ticket locked: no

Description

The OSD which is meant to come up when you tune to a bad channel isn't working, which means you have to run mythtv-setup again and reset the channel.

I'm using a Nova-T.

I've attached my backend and frontend logs.

Attachments (2)

frontend.log (45.8 KB) - added by John Pullan <john.pullan@…> 14 years ago.
backend.log (57.6 KB) - added by John Pullan <john.pullan@…> 14 years ago.

Download all attachments as: .zip

Change History (10)

Changed 14 years ago by John Pullan <john.pullan@…>

Attachment: frontend.log added

Changed 14 years ago by John Pullan <john.pullan@…>

Attachment: backend.log added

comment:1 Changed 14 years ago by John Pullan <john.pullan@…>

I forgot to mention this is with

svn 9051

comment:2 Changed 14 years ago by anonymous

I'm not sure whether this is the same problem that I experience.

In my case, the following happens. I watch a UK DVB broadcast on bbc3 or 4 in the evening, when those channels are broadcasting. I shut down the frontent and go to bed.

I get up in the morning, open up the frontend and choose "watch tv". Now, BBC4 is no longer broadcasting a video stream, though the tuner can tune to it's frequency fine. Since the frontend picks up the last channel it was displaying, it complains that there is no video stream.

Unfortunately, it's very hard to get the channels to change as the frontend goes into watch tv mode, and i find no easy way other way to change channel outside of watch tv mode.

Workaround is to record what I want to watch and view it from the recordings menu as it records.

this is more probably a "failure to get a video stream once tuned" issue than a "failure to tune" one, but I suspect the solution will be the same for either issue, e.g. allow user to change channels from there, hence I include my comments here.

Hope that helps.

comment:3 Changed 14 years ago by Oscar Carlsson

Component: mythtvdvb
Owner: changed from daniel to danielk

comment:4 Changed 14 years ago by adrian.wilkins@…

Since my main user is my 2 year old daughter, and her gran is ... technically stunted ... my new workaround for this is a cron job that runs..

USE mythconverg; UPDATE cardinput SET startchan = 3;

.. periodically ; since channel 3 (ITV1) is a channel that transmits 24/7, this ceases to be a problem.

I think the regression of this fault coincided with WatchTV starting to consume files from local disk instead of streaming from the backend. The log seems to bear this out as it shows signs that the file the frontend is trying to open is absent.

As a suggestion for a fix that would function even in the absence of a more technically correct fix (like streaming the output of the DummyRecorder? to the file in the absense of a stream), might I suggest the addition of a "fallbackchannel" column which identifies a channel that a given tuner can depend upon in this event?

comment:5 Changed 14 years ago by danielk

Resolution: fixed
Status: newclosed

John, please test the latest SVN. I believe the problem is fixed there.

There is also a special fix for the Nova-T tuning problems, go into the card's "Recording Options" pane in mythtv-setup and set the broken driver delay to 200 ms.

comment:6 Changed 14 years ago by ben@…

Resolution: fixed
Status: closedreopened

I just upgraded to latest SVN 9364.

I still have the same issue when tuned to a channel that has stopped broadcasting for the night (for instance the kids have been watching CITV). The only on screen display is the error whilst displaying video message. I can find no way (bar going into the database as suggested above) of then viewing any live TV.

Ben

comment:7 Changed 14 years ago by danielk

Milestone: 0.20
Summary: DVB failure to tune OSD brokenDVB needs to check for audio in PMT when not recording MHEG.
Version: head

This is due to removal of the requirement for audio in the PMT with the MHEG changes in #1341. We should still require this stream if not recording MHEG, based on an MHEG recording profile parameter.

comment:8 Changed 13 years ago by danielk

Resolution: fixed
Status: reopenedclosed

Fixed in [9638].

Note: See TracTickets for help on using tickets.