Opened 14 months ago

Closed 5 weeks ago

#13388 closed Bug Report - General (Abandoned)

mythtv-setup: unable to automagically set xmltvid field

Reported by: ghbittwister Owned by:
Priority: minor Milestone: unknown
Component: MythTV - General Version: v30-fixes
Severity: medium Keywords:
Cc: Ticket locked: no

Change History (4)

comment:1 Changed 14 months ago by gigem

Milestone: needs_triage30.1
Resolution: Invalid
Status: newclosed
Version: Unspecifiedv30-fixes

In the future, please provide all relevant information here in the MythTV bug tracking system. Reports that simply link elsewhere will likely be closed as incomplete.

Last edited 14 months ago by Peter Bennett (previous) (diff)

comment:2 Changed 14 months ago by ghbittwister

Resolution: Invalid
Status: closednew

Bit Twister 2019-01-26 20:54:56 CET

Description of problem: mga7 beta1

mythtv-setup: unable to automagically set xmltvid field

On release 28 I would go through scan for channels to pull in channels from my tuner, run a sql script to change channel number n_n to n.n, then run mythfilldatabase --dd-grab-all. At the end of that the xmltvid field would have the SchedulesDirect? channel id in xmltvid.

On release 30, mythfilldatabase would complain no grabber set, because of the empty xmltvid field/column.

As a result there are no selections in the program guide.

Version-Release number of selected component (if applicable):

How reproducible: Always

Steps to Reproduce:

  1. clean mythtv install
  2. mythtv-setup
  3. Channel Editor
  4. delete all
  5. scan and insert all
  6. pick a channel and note empty xmltvid field

Using Schedules Direct for TV guide info/source.

Using Input Connections Fetch channels from listing source did not appear to do anything other than complete.

Using a SiliconDust? HDHR-US Tech network tuner. Channel numbers come in as n_n. I wrote some sql code to flip the desired channels to n.n.

Workaround for xmltvid was to pull it from a release 28 install and fill it in the release 30 database.

User doing an upgrade will not notice the problem.

comment:3 Changed 4 months ago by thebitpit

You need to set a grabber before you scan the channels:

2.1 Video Sources 2.2 (New video source) 2.3 Move to New video soure > and hit enter 2.4 Name the new video source.

Note that the Schedules direct grabber is already selected.

Save this video source and it will be available when you scan.

Does this fix your problem?

Last edited 4 months ago by thebitpit (previous) (diff)

comment:4 Changed 5 weeks ago by Stuart Auchterlonie

Milestone: 30.1unknown
Resolution: Abandoned
Status: newclosed

No update in over 12 months from original reporter. Closing

Note: See TracTickets for help on using tickets.