Opened 8 weeks ago

Closed 12 days ago

Last modified 6 days ago

#13544 closed Bug Report - General (fixed)

Qt 5.14 : GUI displays a white rectangle.

Reported by: hamelg Owned by: Paul Harrison <paul@…>
Priority: minor Milestone: needs_triage
Component: MythTV - User Interface Library Version: v30-fixes
Severity: medium Keywords:
Cc: Ticket locked: no

Description

Since the upgrade to qt5-5.14, my frontend has displayed a big white rectangle covering the top 3/4 of the myth window when exiting a recording/video playback, and also in some of the menus. Once it's appeared, the only way to get rid is to exit the frontend and restart. The rectangle seems to be part of myth (ie, not another application) Downgrading qt back to 5.13 resolves the issue. (qt5-base, qt5-declarative, qt5-location, qt5-script, qt5-sensors, qt5-webchannel).

The Archlinux users encounter this issue, see the discussion here : https://aur.archlinux.org/packages/mythtv

A screenshot is attached to the report.

Attachments (2)

Screenshot_20191229_154018.png (661.9 KB) - added by hamelg 8 weeks ago.
This screenshot shows the issue.
mythuiwebbrowser.diff (2.1 KB) - added by paul-h 13 days ago.
Possible fix

Download all attachments as: .zip

Change History (15)

Changed 8 weeks ago by hamelg

This screenshot shows the issue.

comment:1 Changed 7 weeks ago by hamelg

I use the mythbuntu theme.

I applied the workaround suggested here to remove the white rectangle : https://forum.mythtv.org/viewtopic.php?f=36&t=3505#p16947

In the file Mythbuntu/base.xml :

    <webbrowser name="basewebbrowser">
        <area>0,0,0,0</area>
    </webbrowser>

comment:2 Changed 4 weeks ago by thebitpit

Bug https://code.mythtv.org/trac/ticket/13566 is a duplicate of this bug.

The actual problem is caused by the creation of an unused child webbrowser window at startup that is never destroyed. The white window is the unused browser window. The display order gets changed so that appears to come and go. It is not on top some of the time. The workaround makes it so small it doesn't get in the way.

Both mythfrontend and mythtv-setup have this bug. I suspect it has been in mythtv for some time. The latest Qt version exposed it by changing the order of visibility.

By the way, editing /usr/share/mythtv/themes/default-wide/base.xml in the gentoo distribution should workabound the problem for wide themes.

comment:3 Changed 2 weeks ago by Peter Bennett

Is this caused by one of the plugins? Check by testing without plugins installed.

comment:4 Changed 2 weeks ago by hamelg

I have no plugins installed and I encounter the issue.

Changed 13 days ago by paul-h

Attachment: mythuiwebbrowser.diff added

Possible fix

comment:5 Changed 13 days ago by paul-h

Status: newinfoneeded_new

Added a possible patch to fix this. Can someone who can reproduce this please test it.

comment:6 Changed 12 days ago by warpme

paul-h, Good work with patch. I tested this on Qt5.14.1 on x86_64 and aarch64. Works perfectly!

comment:7 Changed 12 days ago by Paul Harrison <paul@…>

Owner: set to Paul Harrison <paul@…>
Resolution: fixed
Status: infoneeded_newclosed

In 67ab1a79b7/mythtv:

mythuiwebbrowser: only create the browser window if the parent is not the GlobalObjectStore?

This fixes a bug when using Qt5.14 where an empty browser window sometimes
appears over the GUI. Fixes #13544

comment:8 Changed 12 days ago by Paul Harrison <paul@…>

In 1b4a7f629/mythtv:

mythuiwebbrowser: only create the browser window if the parent is not the GlobalObjectStore?

This fixes a bug when using Qt5.14 where an empty browser window sometimes
appears over the GUI. Fixes #13544

(cherry picked from commit 67ab1a79b7a7d795c51babc5f2c4e89b994574c0)

comment:9 Changed 11 days ago by Paul Harrison <paul@…>

In a32dfc1497/mythtv:

mythuiwebbrowser: only create the browser window if the parent is not the GlobalObjectStore?

This fixes a bug when using Qt5.14 where an empty browser window sometimes
appears over the GUI. Fixes #13544

(cherry picked from commit 67ab1a79b7a7d795c51babc5f2c4e89b994574c0)

comment:10 Changed 11 days ago by Paul Harrison <paul@…>

In 1b4a7f629/mythtv:

mythuiwebbrowser: only create the browser window if the parent is not the GlobalObjectStore?

This fixes a bug when using Qt5.14 where an empty browser window sometimes
appears over the GUI. Fixes #13544

(cherry picked from commit 67ab1a79b7a7d795c51babc5f2c4e89b994574c0)

comment:11 Changed 6 days ago by Paul Harrison <paul@…>

In 67ab1a79b7/mythtv:

mythuiwebbrowser: only create the browser window if the parent is not the GlobalObjectStore?

This fixes a bug when using Qt5.14 where an empty browser window sometimes
appears over the GUI. Fixes #13544

comment:12 Changed 6 days ago by Paul Harrison <paul@…>

In a32dfc1497/mythtv:

mythuiwebbrowser: only create the browser window if the parent is not the GlobalObjectStore?

This fixes a bug when using Qt5.14 where an empty browser window sometimes
appears over the GUI. Fixes #13544

(cherry picked from commit 67ab1a79b7a7d795c51babc5f2c4e89b994574c0)

comment:13 Changed 6 days ago by Paul Harrison <paul@…>

In 1b4a7f629/mythtv:

mythuiwebbrowser: only create the browser window if the parent is not the GlobalObjectStore?

This fixes a bug when using Qt5.14 where an empty browser window sometimes
appears over the GUI. Fixes #13544

(cherry picked from commit 67ab1a79b7a7d795c51babc5f2c4e89b994574c0)

Note: See TracTickets for help on using tickets.