Opened 13 years ago

Closed 13 years ago

#1812 closed defect (invalid)

Some Finnish DVB subtitles are identified as Dutch / Flemish

Reported by: otto at kolsi dot fi Owned by: danielk
Priority: minor Milestone: unknown
Component: mythtv Version: head
Severity: low Keywords:
Cc: Ticket locked: no

Description

In addition to 'normal' DVB subtitles, YLE in Finland has some programs with some kind of enhanced DVB subtitles. In these, texts are e.g. colour coded according to the speaker.

MythTV identifies these subtitles incorrectly as Dutch; Flemish instead of Finnish. The actual subtitles work well, only the language of the subtitles is incorrect. I've added here logs from the mythfrontend and also from the ProjectX and TSReader Lite (if those are for any help).

Mythfrontend:


2006-05-14 21:53:14.063 AFD: Opened codec 0xa83a020, id(MP3) type(Audio) 
2006-05-14 21:53:14.063 AFD: Audio Track #1 is A/V stream #1 and has 0 channels in the Finnish language(6711662). 
2006-05-14 21:53:14.063 AFD: Stream #2, has id 0x2321 codec id DVB_VBI, type Data, bitrate 0 at 0x0xa83a520 
2006-05-14 21:53:14.063 AFD: data codec (Data) 
2006-05-14 21:53:14.063 AFD: Stream #3, has id 0x1050 codec id DVB_SUBTITLE, type Subtitle, bitrate 0 at 0x0xa830b10 
2006-05-14 21:53:14.064 AFD: subtitle codec (Subtitle) 
2006-05-14 21:53:14.064 AFD: Looking for decoder for DVB_SUBTITLE 
2006-05-14 21:53:14.064 AFD: Opened codec 0xa830bd0, id(DVB_SUBTITLE) type(Subtitle) 
2006-05-14 21:53:14.064 AFD: Subtitle track #1 is A/V stream #3 and is in the Dutch; Flemish language(6583668). 
2006-05-14 21:53:14.064 AFD: Stream #4, has id 0x3110 codec id DSMCC_B, type Data, bitrate 0 at 0x0xa7e97c0 
2006-05-14 21:53:14.064 AFD: data codec (Data) 
2006-05-14 21:53:14.064 AFD: Stream #5, has id 0x3111 codec id DSMCC_B, type Data, bitrate 0 at 0x0xa831240 
2006-05-14 21:53:14.065 AFD: data codec (Data) 
2006-05-14 21:53:14.065 AFD: Stream #6, has id 0x3112 codec id DSMCC_B, type Data, bitrate 0 at 0x0xa831300 
2006-05-14 21:53:14.065 AFD: data codec (Data) 
2006-05-14 21:53:14.065 AFD: Stream #7, has id 0x3113 codec id DSMCC_B, type Data, bitrate 0 at 0x0xa8313b0 
2006-05-14 21:53:14.065 AFD: data codec (Data) 
2006-05-14 21:53:14.065 AFD: Stream #8, has id 0x3114 codec id DSMCC_B, type Data, bitrate 0 at 0x0xa831460 
2006-05-14 21:53:14.066 AFD: data codec (Data) 
2006-05-14 21:53:14.066 AFD: Stream #9, has id 0x3115 codec id DSMCC_B, type Data, bitrate 0 at 0x0xa831510 
2006-05-14 21:53:14.066 AFD: data codec (Data) 
2006-05-14 21:53:14.066 AFD: Stream #10, has id 0x3116 codec id DSMCC_B, type Data, bitrate 0 at 0x0xa83d900 
2006-05-14 21:53:14.066 AFD: data codec (Data) 
2006-05-14 21:53:14.066 AFD: Stream #11, has id 0x3117 codec id DSMCC_B, type Data, bitrate 0 at 0x0xa83ed10 
2006-05-14 21:53:14.066 AFD: data codec (Data) 

ProjectX:


-> Filetype is TS (generic PES Container)
-> demux
-> Service ID 0x1
-> PMT 0x100 refers to these usable streams:
Video:
PID: 0x200(#0)
Audio:
PID: 0x28A(fin)(#138)
Teletext:
PID: 0x911(fin_i100 )
Subpict.:
n/a
-> special PIDs for searching defined: { 0x911 }
ok> PID 0x911 has PES-ID 0xBD (private stream 1) (TTX)  (22748 #122) 

TSReader Lite:


Program Number: 1
PCR on PID 128 (0x0080)
PMT Version: 4

Stream Type: 0x02 MPEG-2 Video
 Elementary Stream PID 512 (0x0200)

Stream Type: 0x04 MPEG-2 Audio
 Elementary Stream PID 650 (0x028a)

Stream Type: 0x06 Teletext/VBI
 Elementary Stream PID 2321 (0x0911)

Stream Type: 0x05 ISO/IEC 13818-1 private_sections
 Elementary Stream PID 3120 (0x0c30)

Stream Type: 0x0b ISO/IEC 13818-6 type B
 Elementary Stream PID 3110 (0x0c26)

Stream Type: 0x0b ISO/IEC 13818-6 type B
 Elementary Stream PID 3111 (0x0c27)

Stream Type: 0x0b ISO/IEC 13818-6 type B
 Elementary Stream PID 3112 (0x0c28)

Stream Type: 0x0b ISO/IEC 13818-6 type B
 Elementary Stream PID 3113 (0x0c29)

Stream Type: 0x0b ISO/IEC 13818-6 type B
 Elementary Stream PID 3114 (0x0c2a)

Stream Type: 0x0b ISO/IEC 13818-6 type B
 Elementary Stream PID 3115 (0x0c2b)

Stream Type: 0x0b ISO/IEC 13818-6 type B
 Elementary Stream PID 3116 (0x0c2c)

Stream Type: 0x0b ISO/IEC 13818-6 type B
 Elementary Stream PID 3117 (0x0c2d)

Stream Type: 0x0c ISO/IEC 13818-6 type C
 Elementary Stream PID 3119 (0x0c2f)

Change History (3)

comment:1 Changed 13 years ago by ksalmela at lanwan fi

Most likely this is not a bug but a designed feature from YLE (Finnish Broadcasting Company)

http://www.kuulonhuoltoliitto.fi/tiedoston_katsominen.php?dok_id=565

comment:2 Changed 13 years ago by ksalmela at lanwan fi

Basically it says in Finnish that YLE uses "flemish" language code for descriptive finnish subtitles for people with hearing disabilities.

comment:3 Changed 13 years ago by Isaac Richards

Resolution: invalid
Status: newclosed

Not a mythtv bug, then.

Note: See TracTickets for help on using tickets.