Opened 13 years ago

Closed 13 years ago

#1941 closed defect (duplicate)

Incorrect (slow) OSD program durations for some (not all) 1080i recordings

Reported by: ylee@… Owned by: Isaac Richards
Priority: minor Milestone: unknown
Component: mythtv Version: 0.20
Severity: low Keywords: osd slow incorrect time times duration length recording 1080i cable movies
Cc: Ticket locked: no

Description

*All* HD recordings from the 1080i premium-movie channels I subscribe to (HBO HD, Showtime HD, CineMAX HD, Starz! HD) have incorrect recording lengths. A two-hour recording will typically show a total recording time of about one hour and 40 minutes, although the recording is complete with no missing chunks (jumping to the last minute of the movie's OSD length does properly takes me to the last minute of the actual recording). For example, a snippet of _The Paper_ recorded from Showtime HD that, according to my watch, took 30 seconds to play, will according to the OSD have taken about 26 seconds.

This issue does *not* occur with recordings from any other source, whether 1080i/720p broadcast-network affiliates (including movies they broadcast in HD), 1080i all-HD channels like HDNet/HDNet movies and Discovery HD, or analog cable channels. Even more peculiarly, this also does not occur with other video on the affected premium-movie channels; for example, with a just-recorded recording of _Robin Hood: Prince of Thieves_ (150-minute recording the OSD says is two hours and 16 minutes long), the commercials for other movies ahead of the movie itself, at the top of the recording, all play with proper elapsed time, but the movie itself plays with the aforementioned slow OSD time.

I presume the isue has something to do with the difference between films' 24fps and the NTSC/HD 29.97fps refresh rates, but am puzzled by why this is only an isue with the aforementioned 1080i channels but not the others. I suppose this could be related to #1693 but I have never seen OSD times doubled.

This is an issue I've noticed since first setting up my MythTV box six months ago, on 0.18.1, and has continued through 0.19 and 0.19.1 (all through the ATrpms packages). The recordings are, again, complete, and otherwise play fine at the normal speed. They are *not* sped up in any way; I've tried playing the affected recordings at 0.8X time, approximating the 24/29.97 difference, and that's clearly too slow. (If it matters, I use Bob deinterlacing, but I use it everywhere, including the recordings from the sources without this issue.)

Change History (3)

comment:1 Changed 13 years ago by danielk

Resolution: duplicate
Status: newclosed

Duplicate of #799.

comment:2 Changed 13 years ago by ylee@…

Resolution: duplicate
Status: closedreopened
Version: 0.190.20

Two points:

  • The issue still exists in 0.20 (ATrpms).
  • As I and others have recently noted, this issue has for the first time emerged on video from KNTV, the San Francisco Bay-area 1080i NBC affiliate (and which recently installed new encoder hardware). As with the premium-movie channels, filmed programming (Studio 60) triggers the bug while videotaped programming (Leno, Conan) does not.

I have reopened the ticket as I don't see this as a duplicate of #799. Similar, of course, but not identical. #799 seems mostly to affect 720p and other 59.94-fps programming, while this only affects 24-fps programming shown on certain 1080i, 29.97-fps channels.

comment:3 Changed 13 years ago by Isaac Richards

Resolution: duplicate
Status: reopenedclosed

It's the same issue.

Note: See TracTickets for help on using tickets.