Opened 13 years ago

Closed 13 years ago

Last modified 13 years ago

#1942 closed defect (invalid)

mythtv-0.19_p9163-r1 backend crash

Reported by: anonymous Owned by: Isaac Richards
Priority: minor Milestone: unknown
Component: mythtv Version:
Severity: medium Keywords:
Cc: Ticket locked: no

Description

Periodically (about once or twice a week), mythbackend 0.19 terminates. I see the following in /var/log/mythtv/mythbackend.log:

2006-06-09 20:00:34.837 Using runtime prefix = /usr 2006-06-09 20:00:34.927 New DB connection, total: 1 2006-06-09 20:00:34.964 Connected to database 'mythconverg' at host: localhost [mpeg @ 0xb75ea360]Parser not found for Codec Id: 94210 ! [mpeg2video @ 0xb75134a0]ac-tex damaged at 14 18 [mpeg2video @ 0xb75134a0]Warning MVs not available 0: start_time: 0.036 duration: 5.727 1: start_time: 995.109 duration: 5.787 2: start_time: 0.026 duration: 5.700 stream: start_time: 0.289 duration: 11120.772 bitrate=24 kb/s Starting up as the master server. 2006-06-10 13:24:35.014 Using runtime prefix = /usr 2006-06-10 13:24:35.030 New DB connection, total: 1 2006-06-10 13:24:35.038 Connected to database 'mythconverg' at host: localhost [mpeg @ 0xb75c2360]Parser not found for Codec Id: 94210 ! [mpeg2video @ 0xb74eb4a0]ac-tex damaged at 14 18 [mpeg2video @ 0xb74eb4a0]Warning MVs not available 0: start_time: 0.036 duration: 5.727 1: start_time: 995.109 duration: 5.787 2: start_time: 0.026 duration: 5.700 stream: start_time: 0.289 duration: 11120.772 bitrate=24 kb/s [mpeg @ 0xb75bb360]Parser not found for Codec Id: 94210 !

The crash happened at about 20:01. I restarted it at 13:24 the next day:

# /etc/init.d/mythbackend zap # /etc/init.d/mythbackend start

I am running Gentoo with mysql 4.0.35-r2, and mythtv-0.19_p9163-r1 compiled with +alsa +arts _dvd _lirc +oggvorbis +opengl

Any ideas what might be happening? Gentoo told me to report this bug upstream. http://bugs.gentoo.org/show_bug.cgi?id=136326

Gentoo Base System version 1.6.13 Portage 2.0.54-r2 (default-linux/x86/2005.1, gcc-3.3.6, glibc-2.3.5-r2, 2.6.13-gentoo-r3 i686) ================================================================= System uname: 2.6.13-gentoo-r3 i686 Intel(R) Pentium(R) 4 CPU 3.00GHz ccache version 2.3 [disabled] dev-lang/python: 2.3.5, 2.4.1-r1 dev-python/pycrypto: [Not Present] dev-util/ccache: 2.3 dev-util/confcache: [Not Present] sys-apps/sandbox: 1.2.11 sys-devel/autoconf: 2.13, 2.59-r6 sys-devel/automake: 1.4_p6, 1.5, 1.6.3, 1.7.9-r1, 1.8.5-r3, 1.9.6-r1 sys-devel/binutils: 2.15.92.0.2-r10 sys-devel/libtool: 1.5.18-r1 virtual/os-headers: 2.6.11-r2 ACCEPT_KEYWORDS="x86" AUTOCLEAN="yes" CBUILD="i686-pc-linux-gnu" CFLAGS="-O2 -march=pentium4" CHOST="i686-pc-linux-gnu" CONFIG_PROTECT="/etc /usr/kde/2/share/config /usr/kde/3.4/env /usr/kde/3.4/share/config /usr/kde/3.4/sh utdown /usr/kde/3/share/config /usr/lib/X11/xkb /usr/share/config /var/qmail/control" CONFIG_PROTECT_MASK="/etc/eselect/compiler /etc/gconf /etc/terminfo /etc/env.d" CXXFLAGS="-O2 -march=pentium4" DISTDIR="/usr/portage/distfiles" FEATURES="autoconfig distlocks sandbox sfperms strict" GENTOO_MIRRORS="ftp://mirrors.tds.net/gentoo http://mirror.gentoo.gr.jp http://mirror.datapipe.net/gent oo http://mirror.tucdemonic.org" MAKEOPTS="-j2" PKGDIR="/usr/portage/packages" PORTAGE_TMPDIR="/var/tmp" PORTDIR="/usr/portage" SYNC="rsync://rsync.namerica.gentoo.org/gentoo-portage" USE="x86 X a52 aac alsa apache2 apm arts audiofile avi berkdb bitmap-fonts bzip2 cdda cdio cli crypt cu ps curl dri dts dvd eds emacs emboss encode esd exif expat fam ffmpeg flac foomaticdb fortran gd gdbm g if gpm gstreamer gtk2 idn imlib ipv6 isdnlog jpeg lcms libg++ libwww lirc live mad matroska mhash mikmo d mmx mng motif mp3 mpeg mysql mythtv ncurses nls ogg oggvorbis opengl oss pam pcre pdflib perl png ppp d python quicktime readline reflection sdl session spell spl sse sse2 ssl stream svga tcpd theora tiff transcode truetype truetype-fonts type1-fonts udev usb vcd vlm vorbis win32codecs wmv xine xinerama xml 2 xmms xorg xv xvid zlib userland_GNU kernel_linux elibc_glibc" Unset: ASFLAGS, CTARGET, INSTALL_MASK, LANG, LC_ALL, LDFLAGS, LINGUAS, PORTAGE_RSYNC_EXTRA_OPTS, PORTA GE_RSYNC_OPTS, PORTDIR_OVERLAY

Change History (5)

comment:1 Changed 13 years ago by Isaac Richards

Resolution: invalid
Status: newclosed

Need backtrace.

comment:2 Changed 13 years ago by anonymous

Thanks! I was wondering if it would be worth my while to put time into troubleshooting this and other issues for mythtv. Now I know better!

comment:3 Changed 13 years ago by buzz@…

[I post this here, since the 'anonymous' poster doesn't give their name, or whether they are on any mythtv email lists......] Maybe I can help interpret Isaac's comment... "need backtrace" means: "Without a backtrace provided by the original poster, I am unable to diagnose this problem further, and until then I will set it as 'invalid' or 'closed' so that other developers know not to spend their time trying to look into it further." It also means: "Could the original poster please provide a backtrace." From the wiki: "Your best bet for getting help determining the cause of the problem is to download the myth source code and compile it yourself in debug mode, then run it with gdb, the GNU debugger. Only with a backtrace can the developers really help you if your setup is causing Myth to segfault." See: http://mythtv.org/docs/mythtv-HOWTO-22.html#ss22.2"

comment:4 Changed 13 years ago by bryce@…

Thanks, sorry for being a jerk, I didn't realize bugs were closed/invalid when they just need more info, as a matter of policy as documented at that howto. I guess mythtv must get a lot of bugs to require such a policy. I had spent a lot of time searching for a solution before coming to this bug tracker and was upset that it was rejected. But as stated in that howto, it is no use getting upset at the person who may be able to fix the problem.

Anyway, as I mentioned in the original bug report, the bug occurs very infrequently, but has happened about once a week since I upgraded to 0.19. (I was running 0.18.1 prior to that for several months on the same hardware with the same driver, so I am assuming it is something in mythtv, but don't really know.) I have set up mythbackend in gdb on the chance I can get a backtrace the next time it crashes. I wish I knew a better way to trigger the condition that produces the crash so I could provide this requested information more quickly.

Well, I don't know if anyone looks at bugs once they're closed but figured just in case I want to explain that I'm not refusing to provide this information, I just do not have it and do not expect to get it quickly. And I'm sorry for the smartass reply to ijr.

comment:5 Changed 13 years ago by anonymous

#0 0xb65368ab in write () from /lib/libpthread.so.0 #1 0xb6037fdc in ?? () from /usr/lib/libmysqlclient.so.14 #2 0x00000001 in ?? () #3 0xb602fe66 in vio_write () from /usr/lib/libmysqlclient.so.14 #4 0xb603169f in net_real_write () from /usr/lib/libmysqlclient.so.14 #5 0xb6031174 in net_flush () from /usr/lib/libmysqlclient.so.14 #6 0xb603142a in net_write_command () from /usr/lib/libmysqlclient.so.14 #7 0xb602b5d7 in cli_advanced_command () from /usr/lib/libmysqlclient.so.14 #8 0xb602e333 in mysql_send_query () from /usr/lib/libmysqlclient.so.14 #9 0xb602e3b3 in mysql_real_query () from /usr/lib/libmysqlclient.so.14 #10 0xb7f892c0 in QMYSQLResult::reset ()

from /usr/qt/3/plugins/sqldrivers/libqsqlmysql.so

#11 0xb6b0a607 in QSqlQuery::exec () from /usr/qt/3/lib/libqt-mt.so.3 #12 0xb72117b2 in MSqlQuery::exec () from /usr/lib/libmyth-0.19.so.0 #13 0xb6b0bd6e in QSqlQuery::exec () from /usr/qt/3/lib/libqt-mt.so.3 #14 0x08067615 in MSqlQuery::exec () #15 0x080c3a80 in QPtrList<ProgramInfo?>::deleteItem () #16 0x080b35ab in QPtrList<ProgramInfo?>::deleteItem () #17 0x080bac26 in QPtrList<ProgramInfo?>::deleteItem () #18 0x080beb01 in QPtrList<ProgramInfo?>::deleteItem () #19 0xb6530f2a in pthread_start_thread () from /lib/libpthread.so.0 #20 0xb65310c9 in pthread_start_thread_event () from /lib/libpthread.so.0 #21 0xb63ee50a in clone () from /lib/libc.so.6

Note: See TracTickets for help on using tickets.