Opened 13 years ago

Closed 13 years ago

#2215 closed defect (fixed)

Internal player lockup and crash

Reported by: Anduin Withers Owned by: skamithi
Priority: minor Milestone: unknown
Component: mythtv Version:
Severity: medium Keywords:
Cc: Ticket locked: no

Description

Although these were using libmpeg2 I can reproduce them at will with ffmepg.

The best way for me to reproduce this is to skip forward and the jump back (quickly, not 100% but up there). It should also be noted that this is simply the best way I've found to reproduce a hang or crash, rather innocent use has produced the same result for me.

I'm submitting this against the internal DVD player as this works otherwise (playing normal recordings, playing .mpg files with MythVideo?, etc).

I'll look into this more tonight but my familiarity with that section is lacking.

Attachments (2)

dvdcrash.txt (16.2 KB) - added by Anduin Withers 13 years ago.
dvdhang.txt (14.5 KB) - added by Anduin Withers 13 years ago.

Download all attachments as: .zip

Change History (7)

Changed 13 years ago by Anduin Withers

Attachment: dvdcrash.txt added

Changed 13 years ago by Anduin Withers

Attachment: dvdhang.txt added

comment:1 Changed 13 years ago by skamithi

Status: newassigned

i'll look into into it on wed, if u haven't figured out what's wrong by then.

comment:2 Changed 13 years ago by skamithi

awithers says r10900 resolved the crash. hang is still reproducible. attempting to reproduce the hang.

comment:3 Changed 13 years ago by skamithi

i can't reproduce this. tried it on 2 pcs. one is pentium4 2Ghz with nvidia card. the other is a pentiumM with a ati card. both run gentoo .

comment:4 Changed 13 years ago by skamithi

something that may be related. on my dev PC if i use mergedFB, and run the internal dvd player, and use sticky ffw/rew, i run into the situation where the video buffer queue gets filled up with limbo frames.

mythtv hangs.

i think it may be related to what you see. i'm going to attempt and resolve this issue in a few weeks, then ask u if this fixes your issue.

comment:5 Changed 13 years ago by skamithi

Resolution: fixed
Status: assignedclosed

unreproducible.

Note: See TracTickets for help on using tickets.