Opened 13 years ago

Closed 13 years ago

#2223 closed defect (fixed)

Recent mythvideo changes incompatible with GCC 3.3?

Reported by: Nigel Owned by: Nigel
Priority: minor Milestone: 0.20
Component: mythtv Version: head
Severity: medium Keywords:
Cc: Ticket locked: no

Description

Lots of errors like:

g++ ... -o metadatalistmanager.o metadatalistmanager.cpp
In file included from /usr/include/gcc/darwin/3.3/c++/bits/stl_algobase.h:67,
                 from /usr/include/gcc/darwin/3.3/c++/list:67,
                 from metadatalistmanager.cpp:1:
/usr/include/gcc/darwin/3.3/c++/cstdlib:139: error: `_Exit' not declared
/usr/include/gcc/darwin/3.3/c++/cstdlib:165: error: `_Exit' not declared

which seem to be a compiler bug caused by having an STL header as the first #include in the file. Moving them around fixes the error. I will check in the changes when I have had some sleep, and tested building on Linux (GCC 3.3.5 ?)

Change History (3)

comment:1 Changed 13 years ago by Nigel

(In [10915]) Reorder #includes so that STL headers aren't first, to work around GCC 3.3 bug. See #2223

comment:2 Changed 13 years ago by Nigel

(In [10943]) Re-order STL includes, GCC 3.3 fix. See #2223

comment:3 Changed 13 years ago by Nigel

Resolution: fixed
Status: newclosed

No more occurances of that fault. Hopefully I can remember the fix if it happens again!

Note: See TracTickets for help on using tickets.