Modify
Warning Please read the Ticket HowTo before creating or commenting on a ticket. Failure to do so may cause your ticket to be rejected or result in a slower response.

Opened 8 years ago

Closed 8 years ago

#2238 closed patch (fixed)

Mute logic fails on cards using v4l1-compat

Reported by: devel@… Owned by: danielk
Priority: minor Milestone: 0.21
Component: mythtv Version: head
Severity: medium Keywords: mute v4l compat saa7134
Cc: mythtv-dev@… Ticket locked: no

Description

Cards that use v4l1-compat for v4l1 support (eg. saa7134) do not set VIDEO_VC_MUTE in VIDIOGCHAN.

As a result, the mute logic in NuppelVideoRecorder?.cpp will never pass.
The fix would seem to be to test VIDIOGCAUDIO directly.

See: http://mythtv.org/pipermail/mythtv-users/2004-January/027927.html
and tvtime sourcecode.

Please find attached patch to change muting logic.

Thanks!

Attachments (1)

mythtv_v4l1-compat_mute_fix.diff (1.1 KB) - added by devel@… 8 years ago.
Patch to fix mute logic for cards using v4l1-compat layer

Download all attachments as: .zip

Change History (3)

Changed 8 years ago by devel@…

Patch to fix mute logic for cards using v4l1-compat layer

comment:1 Changed 8 years ago by danielk

  • Milestone set to 0.21
  • Owner changed from ijr to danielk

comment:2 Changed 8 years ago by danielk

  • Resolution set to fixed
  • Status changed from new to closed

(In [11376]) Fixes #2238. Workaround for Linux kernel bug in v4l-compat.

The problem is that the Linux kernel doesn't properly report the presence or absence of audio capture hardware when using v4l-compat. But if you try to get the volume level and mute status it will return it if audio hardware is present. So the workaround is fairly simple, we just check the volume first and use the sometimes flaky flag to decide whether a failure should be reported as an error or a warning. If the kernel says there is audio hardware we report an error when the audio get fails, otherwise you need to run with "-v audio" to see the error message (since this will fail normally with most frame-grabbers).

Add Comment

Modify Ticket

Action
as closed .
The resolution will be deleted. Next status will be 'new'.
Author


E-mail address and user name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.