Opened 13 years ago

Closed 13 years ago

#2524 closed patch (wontfix)

Move cursor to newer recording after adding to playlist

Reported by: sphery <mtdean@…> Owned by: danielk
Priority: trivial Milestone: 0.21
Component: mythtv Version: 0.20
Severity: low Keywords:
Cc: Ticket locked: no

Description

Currently, after adding a recording to a playlist, if the cursor is not in the title column, the cursor is moved down to the next recording in the list. When the user enables PlayBoxOrdering (List Newest Recording First--which is the default setting), that means that the cursor moves to an older recording. Since you have to add recordings in the order you plan to watch them, adding recordings in order would then require moving up two recordings, add to playlist, move up two recordings, etc.

The attached patch simply checks the value of PlayBoxOrdering and moves up if newest recordings are shown first or down if oldest recordings are shown first.

This patch may make things less intuitive in a couple of situations. First, if the user is planning to play back the playlist in a random order (Shuffle Play), it may seem strange to move to the bottom of the list to start adding recordings. Also, moving to the bottom could be similarly strange if the user is creating a playlist for some purpose other than playback (i.e. deleting, changing recording or playback group, or setting job options for several recordings). I think, however, that since the cursor will always move up or down for a particular user (based on PlayBoxOrdering), it will be easy to adapt--even for those who don't use playlists for playing recordings.

This also has the downside that if a user removes a recording from a playlist, it will scroll to a newer recording rather than an older recording (i.e. for removing a bunch of just-added recordings from the playlist one by one). I considered checking whether we were adding or removing the item, also, but thought that may make the behavior hard to predict for the user (especially when the older recording is not in the playlist). If you would prefer that the cursor moves to an older recording upon removing an item from the playlist, please let me know and I'll modify the patch.

Attachments (1)

mythtv-cursor_movement_after_adding_to_playlist.patch (461 bytes) - added by sphery <mtdean@…> 13 years ago.

Download all attachments as: .zip

Change History (3)

Changed 13 years ago by sphery <mtdean@…>

comment:1 Changed 13 years ago by danielk

Milestone: unknown0.21
Owner: changed from Isaac Richards to danielk
Priority: minortrivial
Severity: mediumlow

comment:2 Changed 13 years ago by danielk

Resolution: wontfix
Status: newclosed

I took this ticket because it seemed like the selection code was sometimes not moving the cursor at all. But I can no longer reproduce that bug.

I've also tried this patch and I can see it being very confusing to switch the cursor movement direction, which was the conclusion reached the when this was first discussed. The use case for when this is fairly uncommon, basically when you are constructing a list for playback and the order is reversed (i.e. not when you are marking the recordings for any other reason.) Now that we've added John Poet's patch for ordering the All Programs list in a different order from the program lists this is fairly easy to work around by always having the recordings in descending order based on time recording.

Note: See TracTickets for help on using tickets.