Opened 13 years ago

Closed 13 years ago

#2597 closed defect (invalid)

Teletext window not centered in various zoom modes

Reported by: anonymous Owned by: danielk
Priority: minor Milestone: 0.21
Component: mythtv Version: head
Severity: medium Keywords:
Cc: Ticket locked: no

Description

watching teletext on my PVR350 card is not okay in "4:3 Zoom", "16:9 Zoom" and "16:9 Zoom strechted" modes. the teletext window is not centered (and therefore cut off).

Attachments (1)

2597-v1.patch (11.4 KB) - added by barnasc 13 years ago.

Download all attachments as: .zip

Change History (9)

comment:1 Changed 13 years ago by barnasc

Problem confirmed. I will look into this to create a patch.

Changed 13 years ago by barnasc

Attachment: 2597-v1.patch added

comment:2 Changed 13 years ago by barnasc

2597-v1.patch now applies the screen offsets (xoff and yoff) correctly to display teletext pages in all screen modes.

comment:3 Changed 13 years ago by anonymous

Type: defectpatch

comment:4 Changed 13 years ago by danielk

Owner: changed from Isaac Richards to danielk
Version: 0.20head

comment:5 Changed 13 years ago by danielk

Type: patchdefect

barnasc, I don't think this patch is correct.

Shouldn't you just be able to call OSD::Reinit() with the new visibleBounds when in a zoom mode (when using a software composited OSD, you should not do this when using a ChromaKey? or OpenGL OSD).

-- Daniel

comment:6 Changed 13 years ago by barnasc

Just reviewed the OSDTypeCC classes. In here, the initialization and Reinit() functions store the display offsets in local member class variables which are used for the different drawing routines. Is this what you prefer?

Martin

comment:7 Changed 13 years ago by barnasc

Got it. In the OSDType708CC class, CalcBounds?() measures the window size and this is applied in the original Draw() routine without parsing xoff and yoff. Instead, it calls the other Draw() function using the upper left corner information. Will see how I can apply this on the Teletext stuff.

For some reason, the older OSD classes do not have a CalcBounds?() but still use xoff, yoff. What is the reason of this?

Martin

comment:8 Changed 13 years ago by danielk

Resolution: invalid
Status: newclosed

Yep, just use OSDType708CC as a guide. The older classes don't use CalcBounds?() because they were written before it was and haven't been ported yet. E-mail me with any additional questions.

Reopen the ticket when you have a new patch ready for review.

Note: See TracTickets for help on using tickets.