Modify

Opened 11 years ago

Closed 11 years ago

#2740 closed defect (fixed)

mytharchive: chooses wrong dvd-device for "Native archive" job

Reported by: tormen <tormen@…> Owned by: paulh
Priority: minor Milestone: unknown
Component: mythtv Version: 0.20
Severity: medium Keywords: setup dvd device
Cc: tormen@… Ticket locked: no

Description

gentoo media-plugins/mytharchive version: 0.20_p11222
gentoo media-tv/mythtv version: 0.20_p11626

Within mythfrontend I chose the following settings:

  • Utilities/Setup?
  • Setup
  • Media Settings
  • Archive File Settings
    • Location of DVD: /dev/dvdwriter2

I created a Video-dvd first. This worked flawlessly. (thnx, great work!)

Now I tried to create a "Native archive". This failed. Because mytharchive tried to access /dev/dvd.

--->

Logfile of Mytharchive: progress.log:

2006-11-27 21:51:08.976 Copy completed OK
2006-11-27 21:51:08.976 Item Archived OK
2006-11-27 21:51:09.042 Burning ISO image to /dev/dvd
:-( /dev/dvd: media is not recognized as recordable DVD: 0
2006-11-27 21:51:10.154 ERROR: Failed while running growisofs. Result: 252

Attachments (0)

Change History (7)

comment:1 Changed 11 years ago by paulh

  • Owner changed from ijr to paulh

comment:2 follow-up: Changed 11 years ago by tormen

The problem must be in mytharchivehelper. mythburn.py seems ok (<<< I looked into it - the advantage of script-files :-) But I suppose you will know this ;-)

tormen.

comment:3 in reply to: ↑ 2 Changed 11 years ago by paulh

Replying to tormen:

The problem must be in mytharchivehelper. mythburn.py seems ok (<<< I looked into it - the advantage of script-files :-) But I suppose you will know this ;-)

tormen.

Yep. That is where you would think the problem would be, except I can't reproduce it at all. Have you been able to reproduce it a second time?

Looking at the code the only way I can see it produce this problem is if for some reason gContext->GetSetting?("MythArchiveDVDLocation", "/dev/dvd") fails to retrieve the setting from the DB and uses the default setting.

What does running this query in mysql give? SELECT * FROM settings WHERE value = "MythArchiveDVDLocation";

Was you running on the same host both times?

comment:4 Changed 11 years ago by tormen <tormen@…>

Hi.

Yes, I am able to reproduce! I checked mythburn.py. Then I reported the bug, gave up and added a symlink /dev/dvd to the right device and then it worked ;-)

Yes mysql and backend and frontend on the same host.

The SELECT gives:

mysql> SELECT * FROM settings WHERE value = "MythArchiveDVDLocation";
+------------------------+-----------------+----------+
| value                  | data            | hostname |
+------------------------+-----------------+----------+
| MythArchiveDVDLocation | /dev/dvdwriter2 | jolie    |
+------------------------+-----------------+----------+
1 row in set (0.03 sec)

Maybe you can provide a DEBUG-version of mytharchivehelper and I send you the output?

tormen.

comment:5 Changed 11 years ago by tormen <tormen@…>

Hi.

When trying to reproduce: My /dev/dvdwriter2 is a SYMLINK (set up by udev) to hda (/dev/hda)!

Maybe this causes the problem for mytharchivehelper? (because for the mythburn.py it was ok with the symlink)

tormen.

comment:6 Changed 11 years ago by paulh

(In [12160]) Fix a typo which was causing the native archive format to always use the default DVD location. Refs #2740.

comment:7 Changed 11 years ago by paulh

  • Resolution set to fixed
  • Status changed from new to closed

(In [12161]) Fix a typo which was causing the native archive format to always use the default DVD location. Fixes #2740.

Add Comment

Modify Ticket

Action
as closed The owner will remain paulh.
The resolution will be deleted. Next status will be 'new'.
Author


E-mail address and user name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.